I had too many Precisions and too little time

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
Very nice, I bought a M90 with a FX 3500M on a whim for the GPU, GPU ended up being one after the recall in 2008 so it's post-Bumpgate :D
 
  • Like
Reactions: Samir

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
I am about to commit sacrilege: selling my M6800 Covet. I just don't use the stupid thing and it's wasted money leaving it in my drawer. Money I could instead be spending on something more useful, especially these days.
 

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
And so my Precision collection becomes smaller every day. Someone on YT of all things has shown interest in both my M40 and M50 and we agreed upon a price.

I'll need to sort shipping to the USA though. Ouch!

He also expressed interest in my other Precisions but is short on cash right now. I'm already glad I can sell off my two oldest Precisions since I don't use them anyway. I'll be keeping the M70, M90, M6300 ES, M6400 Covet and M6500 Covet though, still contemplating selling the M6600.
 
Last edited:

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
In other news, I finally got XP x64 to work on my M6600! Will reinstall Win7 on MBR later so I don't have to screw around with changing from UEFI to BIOS all the time.
 

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
M40, M50 and M4500 gone now. Good, space is nice, filling the ghost town that is my wallet even more so!
 
Last edited:

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
Well since i'm in need of money and I don't even use them that often I decided to pretty much sell off all Precisions at this point.

Think i'll only keep the M6600 since it's the fastest of them all and the M6500 Covet because it's the machine with the most memories.
 

TRANTOR

New Member
Sep 30, 2023
13
0
1
Hello!

I'm having trouble assembling a new display panel for my old laptop Precision M4400.

I ordered the supposedly correct components, but something is not working.

Where am I wrong?

I see you have a collection of Dell laptops.

Can you give me some advice?
20230930_105848.jpg20230930_105343.jpg20230930_105328.jpg
 
Last edited:

TRANTOR

New Member
Sep 30, 2023
13
0
1
The inverter is wrong, the cover must be different?
The inverter has two connectors, but I don't see any cables for them.
Do I need additional cables, from where, what?
 
Last edited:

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
The inverter is wrong, the cover must be different?
The inverter has two connectors, but I don't see any cables for them.
Do I need additional cables, from where, what?
You've got a RGBLED screen which doesn't require a inverter IIRC, you do need the right display cable though.
 

TRANTOR

New Member
Sep 30, 2023
13
0
1
You've got a RGBLED screen which doesn't require a inverter IIRC, you do need the right display cable though.
Thanks!
Can you tell me the model of the cable or a picture of it?
I don't know exactly what to look for.
I saw in your earlier post that you ordered the same parts as me, you should know how you fit things together.
My ribbon cable says it's for an RGB LED display and I can't find another one anywhere.
Maybe I'll just have to plug in and I'll be fine?
But why is the other little connector on the display, that bothers me?!?
I'll try to test with what's available these days, see if it works.
 
Last edited:

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
Thanks!
Can you tell me the model of the cable or a picture of it?
I don't know exactly what to look for.
I saw in your earlier post that you ordered the same parts as me, you should know how you fit things together.
My ribbon cable says it's for an RGB LED display and I can't find another one anywhere.
Maybe I'll just have to plug in and I'll be fine?
But why is the other little connector on the display, that bothers me?!?
I'll try to test with what's available these days, see if it works.
I'm pretty sure the other plug is unused. H161K is the cable you need.
 

TRANTOR

New Member
Sep 30, 2023
13
0
1
Hello again!
I decided to try the panel with this cable first.
IT WORKS!
It works great.
So this cable in the picture works too.
Now I just have to find the right brackets for the panel.
I think they are these:
AM03N000900
AM03N000A00
I'm not sure, but I'm still checking.
I'm also looking for somewhere cheap because I see quite high prices.
I have three pairs of other brackets but they don't fit, they are shorter!
This is my cable:
A1.jpg
 
Last edited:

Wasmachineman_NL

Wittgenstein the Supercomputer FTW!
Aug 7, 2019
1,880
620
113
Hello again!
I decided to try the panel with this cable first.
IT WORKS!
It works great.
So this cable in the picture works too.
Now I just have to find the right brackets for the panel.
I think they are these:
AM03N000900
AM03N000A00
I'm not sure, but I'm still checking.
I'm also looking for somewhere cheap because I see quite high prices.
I have three pairs of other brackets but they don't fit, they are shorter!
This is my cable:
View attachment 32028
You need the dual CCFL brackets for the screen. I made the same mistake.
 

TRANTOR

New Member
Sep 30, 2023
13
0
1
I ordered the ones with the numbers I wrote above.
Terribly expensive order (23 euros) but I can't find anywhere cheaper with delivery.
It was very expensive for me to complete my M4400, I still don't have strong rear caps in excellent condition. But that's it for now.
So far I have spent over 400 euros, but it's my fault, I made a lot of mistakes.
But because I'm stubborn, I keep going.
For the next laptop I will be a lot more careful and do a lot more research beforehand.
Now I have another M4400 and a half almost + almost all E6500.