HPE Switch IP Routing

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

eroji

Active Member
Dec 1, 2015
276
52
28
40
I am having some trouble configuring the HPE 5820X-24XG-SFP+ for ip routing between VLANs. The only L3 switch I have played with so far is the LB4M. I can't seem to find any information online on how exactly to get this part working. I have the VLANs and respective virtual interface IPs configured. I also created the default route to my firewall, however I don't have it connected as I need to reinstall pfsense on it. The switch is basically standalone right now as I program it. The pfsense will be 10.64.100.1 and 5820X is 10.64.100.2. There does not appear to be a command like 'ip routing' to enable inter-VLAN routing.

Code:
display current-configuration
#
 version 5.20.105, Release 1810P13
#
 sysname HP
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system
#
 undo portal local-server https
#
 ip http enable
#
 password-recovery enable
#
vlan 1
#
vlan 10
 description Server Network
#
vlan 20

 description User Network
#
vlan 30
 description Guest Network
#
vlan 50
 description Camera Network
#
vlan 70
 description Misc Network
#
vlan 100
 description Switch Network
#
vlan 110
 description Management Network
#
vlan 200
 description vMotion Network
#
domain system
 access-limit disable
 state active
 idle-cut disable

 self-service-url disable
#
user-group system
 group-attribute allow-guest
#
local-user admin
 password cipher <redacted>
 authorization-attribute level 3
 service-type telnet
 service-type web
#
cwmp
 undo cwmp enable
#
interface NULL0
#
interface Vlan-interface10
 ip address 10.64.10.1 255.255.255.0
#
interface Vlan-interface20
 ip address 10.64.20.1 255.255.255.0
#
interface Vlan-interface30
 ip address 10.64.30.1 255.255.255.0

#
interface Vlan-interface50
 ip address 10.64.50.1 255.255.255.0
#
interface Vlan-interface70
 ip address 10.64.70.1 255.255.255.0
#
interface Vlan-interface100
 ip address 10.64.100.2 255.255.255.0
#
interface Vlan-interface110
 ip address 10.64.110.1 255.255.255.0
#
interface Vlan-interface200
 ip address 10.64.200.1 255.255.255.0
#
interface GigabitEthernet1/0/25
 port link-mode bridge
 port access vlan 100
#
interface GigabitEthernet1/0/26
 port link-mode bridge
 port access vlan 20
#

interface GigabitEthernet1/0/27
 port link-mode bridge
#
interface GigabitEthernet1/0/28
 port link-mode bridge
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/1
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/2
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/3
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/4
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/5
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/6

 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/7
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/8
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/9
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/10
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/11
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/12
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/13
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/14

 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/15
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/16
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/17
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/18
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/19
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/20
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/21
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/22

 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/23
 port link-mode bridge
#
interface Ten-GigabitEthernet1/0/24
 port link-mode bridge
#
 ip route-static 0.0.0.0 0.0.0.0 10.64.100.1 preference 10
#
 snmp-agent
 snmp-agent local-engineid 8000000B03BCEAFA9B0476
 snmp-agent sys-info version v3
#
 ssh server enable
#
 ip https enable
#
 load xml-configuration
#
 load tr069-configuration
#
user-interface aux 0
user-interface vty 0 15

I tried plugging my workstation onto port 26 on VLAN20 and set an IP 10.64.20.2. I can ping the gateway address of 10.64.20.1, however, any interface IP outside of VLAN20 does not reply nor does the switch's IP of 10.64.100.2. Looking at the route table show the following.

Code:
display ip routing-table
Routing Tables: Public
        Destinations : 4        Routes : 4

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

10.64.20.0/24       Direct 0    0            10.64.20.1      Vlan20
10.64.20.1/32       Direct 0    0            127.0.0.1       InLoop0
127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0
127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0
I would really appreciate some guidance on getting this working.
 

eroji

Active Member
Dec 1, 2015
276
52
28
40
Stupid me. Looks like the fact that I had nothing plugged in besides the workstation meant that the switch did not online the VLAN a port belonged to, including the virtual interface. For instance plugging a device into a port that was assigned to VLAN100 brought it online right away and I was able to ping it and access the web UI on that address.