HPE EC200A Xeon D-1518 'hybrid server' on ebay ~$150

t00l1024

New Member
Jul 31, 2020
3
3
1
For anyone interested, I have a copy of the March 2020 HPE Service Pack disc I can share privately. My EC200A came with the original 2016 v1.00 system ROM. This brings it up the latest v2.66 available via entitlement. I can confirm that both Debian and FreeBSD installed without error via remote .iso attach from the iLO Remote Console.
Pretty please!
 
  • Like
Reactions: Samir

t00l1024

New Member
Jul 31, 2020
3
3
1
While I don't have mine yet. But looking at a drawing of the caddies. They seem simple in design.
I will try and bend some thin metal sheet and recreate it. But my backup idea is to mount it to the top cover. Which might be easier.

View attachment 15316
Two options:
  • I set two 3.5" drives in place, but then used several little stick-on rubber feet on the HD that kept everything snug when the cover was on. Computer isn't going to move around much anyways.
  • Second option is using a Corsair Dual SSD Mounting Bracket 3.5" CSSD-BRKT2 (https://www.amazon.com/Corsair-Dual-Mounting-Bracket-CSSD-BRKT2/dp/B016498CK0) as a starting frame, cut and bend parts of the bracket to fit the screw mounts on the board. I had two of these and believe they'll work, but opt'd for the easy rubber foot mount.
 
  • Like
Reactions: Samir

nev_neo

Active Member
Jul 31, 2013
151
40
28
I am setting pfsense on the server right now.
Hey @jak were you able to set it up with pfsense ?
hows the performance ?
I'm looking to move from a VM to baremetal pfsense and wanted to see how well the 366i adapter works (or doesnt).
 
  • Like
Reactions: Samir

Mymlan

Clean, Friendly, and In Stock.
Oct 1, 2013
28
73
13
Hey @jak were you able to set it up with pfsense ?
hows the performance ?
I'm looking to move from a VM to baremetal pfsense and wanted to see how well the 366i adapter works (or doesnt).
I'm running pfSense bare-metal on the base model currently; uses about a sixth of the CPU when pushing a gigabit WAN>LAN, albeit my rules are light and there's no IDS/IPS currently active.
 
  • Like
Reactions: Samir

jak

New Member
Apr 17, 2016
9
6
3
For anyone interested, I have a copy of the March 2020 HPE Service Pack disc I can share privately. My EC200A came with the original 2016 v1.00 system ROM. This brings it up the latest v2.66 available via entitlement. I can confirm that both Debian and FreeBSD installed without error via remote .iso attach from the iLO Remote Console.

Stock firmware upon receipt:

Firmware NameFirmware VersionLocation
iLO2.40 Dec 02 2015System Board
Intelligent Platform Abstraction Data10.7System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v1.00 (04/14/2016)System Board

Firmware post-update:

Firmware NameFirmware VersionLocation
HPE Ethernet 1Gb 4-port 366i Adapter - NIC1.2529.0Embedded
iLO2.73 Feb 11 2020System Board
Intelligent Platform Abstraction Data12.02System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v2.66 (07/19/2019)System Board
I would like a copy please


Hey @jak were you able to set it up with pfsense ?
hows the performance ?
I'm looking to move from a VM to baremetal pfsense and wanted to see how well the 366i adapter works (or doesnt).
Yes I was able to setup and install pfsnes. I actually had more problems with the Adata SU655 SSDs I bought failing.
The performance is pretty good. I never see any problems.


Also, whats the acoustics on this ?
Loud enough to be on a desk ?
At an ambient temperature of 92F I can just faintly hear the fan. It is only noticeable when it first starts up.
 
  • Like
Reactions: Samir

t00l1024

New Member
Jul 31, 2020
3
3
1
Also, whats the acoustics on this ?
Loud enough to be on a desk ?
There's a single fan in the machine, but it's a server-class one. Meaning, it's loud. However, it can probably be replaced by a quiet Noctua one.

Edit: I also have 2 3.5" 7200rpm drives installed, so it's generating more heat that without. No 3.5" drives, it's quiet.
 
  • Like
Reactions: Samir

Brewcat

New Member
Jul 26, 2020
3
3
3
For anyone interested, I have a copy of the March 2020 HPE Service Pack disc I can share privately. My EC200A came with the original 2016 v1.00 system ROM. This brings it up the latest v2.66 available via entitlement. I can confirm that both Debian and FreeBSD installed without error via remote .iso attach from the iLO Remote Console.

Stock firmware upon receipt:

Firmware NameFirmware VersionLocation
iLO2.40 Dec 02 2015System Board
Intelligent Platform Abstraction Data10.7System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v1.00 (04/14/2016)System Board

Firmware post-update:

Firmware NameFirmware VersionLocation
HPE Ethernet 1Gb 4-port 366i Adapter - NIC1.2529.0Embedded
iLO2.73 Feb 11 2020System Board
Intelligent Platform Abstraction Data12.02System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v2.66 (07/19/2019)System Board
Yes, please. Thank you!
 
  • Like
Reactions: Samir

nev_neo

Active Member
Jul 31, 2013
151
40
28
How fast does his "server" post ?
I'm hoping to use it as a pfsense firewall, but I need something that would POST and boot up within a short amount of time. I've had experiences with older HP servers where they too a pretty long time to POST.
Can anyone provide some insight into this ?
I know this might be asking too much, but I haven't seen any videos of this in actual usage. Its a pretty nice form factor that might be just what I need for a Firewall. Hey yall...post vids please :p
 
  • Like
Reactions: Samir

nev_neo

Active Member
Jul 31, 2013
151
40
28
For anyone interested, I have a copy of the March 2020 HPE Service Pack disc I can share privately. My EC200A came with the original 2016 v1.00 system ROM. This brings it up the latest v2.66 available via entitlement. I can confirm that both Debian and FreeBSD installed without error via remote .iso attach from the iLO Remote Console.

Stock firmware upon receipt:

Firmware NameFirmware VersionLocation
iLO2.40 Dec 02 2015System Board
Intelligent Platform Abstraction Data10.7System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v1.00 (04/14/2016)System Board

Firmware post-update:

Firmware NameFirmware VersionLocation
HPE Ethernet 1Gb 4-port 366i Adapter - NIC1.2529.0Embedded
iLO2.73 Feb 11 2020System Board
Intelligent Platform Abstraction Data12.02System Board
Intelligent ProvisioningN/ASystem Board
Redundant System ROMU26 v1.00 (04/14/2016)System Board
Server Platform Services (SPS) Firmware3.0.3.9.1System Board
System Programmable Logic DeviceVersion 0x07System Board
System ROMU26 v2.66 (07/19/2019)System Board
I haven't purchased one as yet, but just in case, Can I get this as well ?
 
  • Like
Reactions: Samir

Mymlan

Clean, Friendly, and In Stock.
Oct 1, 2013
28
73
13
From power to OS init is about 20-30 seconds. It definitely isn't a speed demon on bootup if you find yourself reboot frequently
 
  • Like
Reactions: Samir

nev_neo

Active Member
Jul 31, 2013
151
40
28
From power to OS init is about 20-30 seconds. It definitely isn't a speed demon on bootup if you find yourself reboot frequently
Actually 20-30 seconds might not be bad. Some ML's i've seen take almost 2 minutes to boot to OS
 
  • Like
Reactions: Samir

Geran

Active Member
Oct 25, 2016
332
91
28
38
From power to OS init is about 20-30 seconds. It definitely isn't a speed demon on bootup if you find yourself reboot frequently.
I just tested mine, it takes about a min and a half to go from a cold boot to OS init.
 
  • Like
Reactions: Samir

nev_neo

Active Member
Jul 31, 2013
151
40
28
Lets hope for a video about it in the tinyminimicro project.
I personally think the EC200a is far superior to any of the tinyminimicro's, but it isn't sustainable. Once this current supply runs out, it might be hard to find replacements. Also the upgrades for it are few and pretty hard to find at a reasonable cost. But it does have its own niche - having iLO in such a small footprint is pretty damn good.
 
  • Like
Reactions: Samir and Dark

Dark

Active Member
Mar 9, 2019
172
129
28
I personally think the EC200a is far superior to any of the tinyminimicro's, but it isn't sustainable. Once this current supply runs out, it might be hard to find replacements. Also the upgrades for it are few and pretty hard to find at a reasonable cost. But it does have its own niche - having iLO in such a small footprint is pretty damn good.
iLO and Xeon D-1500 series cpu @ ~$150 is what makes it great. Wish it offered a more traditional PCIe slot.
 
  • Like
Reactions: Samir