HP P420 Smart RAID Controller with 1GB FBWC HANGS HP Workstation Z440

Discussion in 'RAID Controllers and Host Bus Adapters' started by GMATJ, Jul 10, 2019.

  1. GMATJ

    GMATJ New Member

    Joined:
    Jul 10, 2019
    Messages:
    6
    Likes Received:
    0
    Hello everybody

    I got an HP Z440 which was on Bios ver. 01.55 (23Apr2015) with a P420 Smart Controller.

    PC was running Ok . - Boots from SSD on SATA and uses RAID as storage

    Yesterday I upgraded BIOS to latest version v2.48 (11April2019) and when PC is booting initializes Smart Controller and then hangs.

    Taken out the P420 Smart Controller and system runs fine

    A couple of questions

    a) Any idea what is causing this problem ?

    b) Is it possible to downgrade BIOS back to v1.55 or similar so I can get my system working with the P420 ??

    c) If it is where can I get the .bin file (M60_0155.bin) in order to do the downgrade. I have searched on the previous versions Tab on the relevant page but it goes as far v2.32.

    Thank you all for your time and effort to read and contribute

    George
     
    #1
  2. j_h_o

    j_h_o Active Member

    Joined:
    Apr 21, 2015
    Messages:
    361
    Likes Received:
    72
    Before you attempt downgrade... check the PCIe options.

    Are you using UEFI or Legacy boot ROM from the card? Try toggling back to Legacy/BIOS and see if this allows the system to boot. And ensure the SATA SSD is first in the boot order.

    You haven't shared any details about OS configuration, so if this doesn't work, let us know if the SATA SSD is using GPT/UEFI or MBR, and what OS is being used.
     
    #2
  3. GMATJ

    GMATJ New Member

    Joined:
    Jul 10, 2019
    Messages:
    6
    Likes Received:
    0
    Hi and thanks for the reply
    System running Windows 10 Pro/64bit
    BIOS ver before upgrade : V1.15
    BIOS ver after upgrade : V2.48 (see picture from array Config BEFORE update)
    P42o firmware : 6.68
    Some more info
    Using Legacy boot :
    SATA SSD is using MBR connected on SATA 0 port.

    It is very interesting that everything worked fine before the BIOS upgrade.
    After the Upgrade it just hangs as in the attached photo
    You can not even enter BIOS after pressing ESC !!! -
    Take the P420 out of PC - Everything works fine !!
    BTW What to check in the PCIe options ?
     

    Attached Files:

    #3
  4. j_h_o

    j_h_o Active Member

    Joined:
    Apr 21, 2015
    Messages:
    361
    Likes Received:
    72
  5. GMATJ

    GMATJ New Member

    Joined:
    Jul 10, 2019
    Messages:
    6
    Likes Received:
    0
    I could try tomorrow when I get to the office , however I am not quite sure why that would make a difference if the pc hangs just after Raid controller initialization !! - it seems is BIOS related as it never goes beyond that stage to even try to boot !
    There must be something in the communication of the new BIOS with the P420 !! which that "something" was not there in the old BIOS !!
    Drives me crazy !!!
     
    #5
  6. GMATJ

    GMATJ New Member

    Joined:
    Jul 10, 2019
    Messages:
    6
    Likes Received:
    0
    Hello again
    Just to report back to the forum - Here is my 2 cents :

    After a nerve braking say and a strong wish to put the controller (and the PC) under the wheels of my car and hear withe pleasure the crashing sound I have found a solution to the problem.

    I went to BIOS PC and specifically to PCI Express settings and I disabled in the particular slot PCI Express slot ( Gen3 x8- Slot 4) the ability to download its Option ROM.

    Result : Everything runs fine.
    The only drawback on boot you do not have the chance to manage the array controller - But you can do this with HP Array Configuration utility (HP ACU), and/or with HPE Smart Storage Administrator.

    P.S. When getting info from HP ACU for the Array Controller - all temperatures (i.e. Controller Temp, Cache module temp and Capacitor Temp) are reported 0 degrees. So there must be some kind of problem on sensor readings being conveyed to S/W. - It could even be why the P420 option ROM was hanging - Remote but surely possible

    Finishing my report I would like to thank j_h_o who read my post and tried to help. And anybody else who read it but could not contribute.
    Regards from sunny Athens
    G.
     
    #6
  7. YardBouncer

    YardBouncer always yield to the hands-on imperative

    Joined:
    Jul 13, 2019
    Messages:
    41
    Likes Received:
    26
    Good job.

    I have just finished fighting my Z820 + HP P812 combo.
    It was getting stuck in a constant BIOS/reboot loop.

    I think what complicated things was using a 480GB Revodrive 3x2 as a boot device.
    The manual indicates that any secondary controller card has to go in the top slot; all well and good apart from the fact that its a half length slot due to the 2nd CPU fan and the P812 is obscenely long (as in several inches longer than a large video card).

    So I tried it in all the other available slots that were 8x or more. Constant reboot loops and no access to the Z820 BIOS, it just ignored any keypress.

    I finally got it to play nicely by removing it so I could get into the BIOS then disabling the option ROM download for it's slot.
    I don't need access to the BIOS ACU since its not a boot device.

    Its now living happily in one of the 16x slots that are supposedly only for extra GPUs and the Revodrive 3x2 is living in the top half length slot.
    Very similar resolution to yours, in fact I was almost ready to buy a P420 instead because its a smaller card and would fit in the top slot.

    I was going to add this info to the P812 thread until I noticed it's last post was from 2014 and thought people might not appreciate me necro-ing the thread.
    I'm new here and not sure what the rules are for that kind of thing.

    Now waiting on delivery of a 3.2TB Fusion-io card, I'm sure that'll be an interesting and stimulating experience...
    Luckily @acquacow knows a lot about them and is very helpful.
     
    #7
  8. GMATJ

    GMATJ New Member

    Joined:
    Jul 10, 2019
    Messages:
    6
    Likes Received:
    0
    Hello again
    Glad to hear that more guys (YardBouncer) have adopted the "disable option rom" solution.
    After some time now system is working fine.
    However P420 (and I suspect P812 also) run very hot. It seems that some or even more than extra cooling is needed. upload_2019-8-28_21-53-34.png
    upload_2019-8-28_21-55-48.png
    So I added a blower on top of the card - blowing on the top side of the heat sink (luckily found one in my drawers !!!)
    Might you I would think a solution blowing to heat sink from the side would be a lot more effective
    Hope somebody using P420 has come across one.
    If I do - I will report back
     
    #8
Similar Threads: P420 Smart
Forum Title Date
RAID Controllers and Host Bus Adapters HP Smart Array P420 2GB FBWC Jan 1, 2014
RAID Controllers and Host Bus Adapters Slow writes HP P420 Aug 27, 2019
RAID Controllers and Host Bus Adapters HP p420 with consumer SATA HDD [hba mode] Dec 31, 2018
RAID Controllers and Host Bus Adapters P420i and SSDs Sep 8, 2018
RAID Controllers and Host Bus Adapters Looking for Raid or HBA card after I broke my p420 Feb 26, 2018

Share This Page