EMC KNX-STL3 - Only two drives showing

bob_dvb

Active Member
Sep 7, 2018
171
74
28
Not quite London
www.orbit.me.uk
Hi,

I've got my hands on an EMC KNX-STL3 and aside from a UPS shipping issue with the first unit (DOA) the current unit is starting up fine. It came with one Samsung 200GB SAS SSD, two Toshiba SAS 15k 2.5in 600GB disks and 12*2TB HGST(?) disks. I have it connected to an Adaptec ASR-71605 controller with an adapter plate and the enclosure shows up fine.

However, only the two 600GB 15k drives are showing up (the second and third slots), but none of the other disks show up in arcconf. The 15k drives are showing blue lights and the other drives are flashing orange. I've tried plugging the disks in and out, but nothing happens. I want it in JBOD/RAW to use ZFS, but I recognise that I need to format the disks to make them 512k sectors, but I am planning on swapping out the disks for 4TB NAS disks (WD Red Pro).

Does anyone have any suggestions as to how I can get the rest of the drives to show up?

arcconf GETCONFIG 1
Controllers found: 1
----------------------------------------------------------------------
Controller information
----------------------------------------------------------------------
Controller Status : Optimal
Controller Mode : RAID (Expose RAW)
Controller Cache Preservation : Disabled
Channel description : SAS/SATA
Controller Model : Adaptec ASR71605
Controller Serial Number : 3A281336D45
Controller World Wide Name : 50000D1107017080
Controller Alarm : Enabled
Physical Slot : 1
Temperature : 68 C/ 154 F (Normal)
Installed memory : 1024 MB
Global task priority : High
Performance Mode : Default/Dynamic
Host bus type : PCIe
Host bus speed : 8000 MHz
Host bus link width : 8 bit(s)/link(s)
PCI Device ID : 652
Stayawake period : Disabled
Spinup limit internal drives : 0
Spinup limit external drives : 0
Defunct disk drive count : 0
Logical devices/Failed/Degraded : 0/0/0
NCQ status : Enabled
Statistics data collection mode : Disabled
Global Physical Device Write Cache Policy: Drive Specific
Monitor Log Severity Level : Informational
--------------------------------------------------------
RAID Properties
--------------------------------------------------------
Copyback : Disabled
Automatic Failover : Enabled
Background consistency check : Disabled
Background consistency check period : 0
--------------------------------------------------------
Controller BIOS Setting Information
--------------------------------------------------------
Runtime BIOS : Enabled
Array BBS Support : Enabled
Physical Drives Displayed during POST : Disabled
Backplane Mode : IBPI
BIOS Halt on Missing Drive Count : 255
--------------------------------------------------------
Controller Version Information
--------------------------------------------------------
BIOS : 7.5-0 (32084)
Firmware : 7.5-0 (32084)
Driver : 1.2-1 (50983)
Boot Flash : 7.5-0 (32118)
CPLD (Load version/ Flash version) : 7/ 10
SEEPROM (Load version/ Flash version) : 0/ 1

--------------------------------------------------------
Controller Cache Backup Unit Information
--------------------------------------------------------

Overall Backup Unit Status : Not Present

----------------------------------------------------------------------
Logical device information
----------------------------------------------------------------------
No logical devices configured

----------------------------------------------------------------------
Physical Device information
----------------------------------------------------------------------
Device #0
Device is a Hard drive
State : Raw (Pass Through)
Block Size : Unknown
Supported : No, Unsupported sector size
Transfer Speed : SAS 6.0 Gb/s
Reported Channel,Device(T:L) : 0,53(53:0)
Reported Location : Enclosure 0, Slot 1
Reported ESD(T:L) : 2,0(0:0)
Vendor : TOSHIBA
Model : AL13SXB6 CLAR600
Firmware : 0B06
Serial number : X5V0A0T8FBMB
World-wide name : 5000039698385A79
Reserved Size : 0 KB
Total Size : 558280 MB
Write Cache : Disabled (write-through)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off,Reduced rpm
SSD : No
Temperature : Not Supported
----------------------------------------------------------------
Device Phy Information
----------------------------------------------------------------
Phy #0
PHY Identifier : 0
SAS Address : 5000039698385A7A
Attached PHY Identifier : 22
Attached SAS Address : 500604800DBE4EBF
Phy #1
PHY Identifier : 1
SAS Address : 5000039698385A7B
Attached PHY Identifier : 10
Attached SAS Address : 500604800DC1EB3F

Device #1
Device is a Hard drive
State : Raw (Pass Through)
Block Size : Unknown
Supported : No, Unsupported sector size
Transfer Speed : SAS 6.0 Gb/s
Reported Channel,Device(T:L) : 0,54(54:0)
Reported Location : Enclosure 0, Slot 2
Reported ESD(T:L) : 2,0(0:0)
Vendor : TOSHIBA
Model : AL13SXB6 CLAR600
Firmware : 0B06
Serial number : Y490A0PCFBMB
World-wide name : 50000395E8102A69
Reserved Size : 0 KB
Total Size : 558280 MB
Write Cache : Disabled (write-through)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off,Reduced rpm
SSD : No
Temperature : Not Supported
----------------------------------------------------------------
Device Phy Information
----------------------------------------------------------------
Phy #0
PHY Identifier : 0
SAS Address : 50000395E8102A6A
Attached PHY Identifier : 23
Attached SAS Address : 500604800DBE4EBF
Phy #1
PHY Identifier : 1
SAS Address : 50000395E8102A6B
Attached PHY Identifier : 11
Attached SAS Address : 500604800DC1EB3F

Device #2
Device is an Enclosure Services Device
Reported Channel,Device(T:L) : 2,0(0:0)
Enclosure ID : 0
Expander ID : 0
Enclosure Logical Identifier : 500604800DC1EB3E
Expander SAS Address : 500604800DC1EB3F
Type : SES2
Vendor : EMC
Model : Viper LCC
Firmware : 0001
Status of Enclosure Services Device
Fan 1 status : 5300 rpm (Optimal)
Fan 2 status : 5300 rpm (Optimal)
Fan 3 status : 5300 rpm (Optimal)
Fan 4 status : 5300 rpm (Optimal)
Power supply 1 status : Critical
Power supply 2 status : Optimal
Temperature Sensor Status 1 : 22 C/ 71 F (Normal)
Temperature Sensor Status 2 : 26 C/ 78 F (Normal)
Temperature Sensor Status 3 : 17 C/ 62 F (Normal)
Temperature Sensor Status 4 : 20 C/ 68 F (Normal)
Temperature Sensor Status 5 : 19 C/ 66 F (Normal)
Temperature Sensor Status 6 : 22 C/ 71 F (Normal)
Temperature Sensor Status 7 : 16 C/ 60 F (Normal)
Speaker status : Not Available


----------------------------------------------------------------------
Connector information
----------------------------------------------------------------------
Connector #0
Connector Name : CN0

-------------------------------------------------------------------
Lane Information
-------------------------------------------------------------------
Lane #0
Channel ID : 0
Device ID : 0
SAS Address : 50000D1107017080
PHY Identifier : 0
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #1
Channel ID : 0
Device ID : 1
SAS Address : 50000D1107017080
PHY Identifier : 1
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #2
Channel ID : 0
Device ID : 2
SAS Address : 50000D1107017080
PHY Identifier : 3
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #3
Channel ID : 0
Device ID : 3
SAS Address : 50000D1107017080
PHY Identifier : 2
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080


Connector #1
Connector Name : CN1

-------------------------------------------------------------------
Lane Information
-------------------------------------------------------------------
Lane #0
Channel ID : 0
Device ID : 4
SAS Address : 50000D1107017080
PHY Identifier : 7
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #1
Channel ID : 0
Device ID : 5
SAS Address : 50000D1107017080
PHY Identifier : 6
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #2
Channel ID : 0
Device ID : 6
SAS Address : 50000D1107017080
PHY Identifier : 4
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080

Lane #3
Channel ID : 0
Device ID : 7
SAS Address : 50000D1107017080
PHY Identifier : 5
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
SAS Address : 50000D1107017080


Connector #2
Connector Name : CN2

-------------------------------------------------------------------
Lane Information
-------------------------------------------------------------------
Lane #0
Channel ID : 0
Device ID : 8
SAS Address : 50000D1107017080
PHY Identifier : 21
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #0

Lane #1
Channel ID : 0
Device ID : 9
SAS Address : 50000D1107017080
PHY Identifier : 20
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #1

Lane #2
Channel ID : 0
Device ID : 10
SAS Address : 50000D1107017080
PHY Identifier : 22
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #2

Lane #3
Channel ID : 0
Device ID : 11
SAS Address : 50000D1107017080
PHY Identifier : 23
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #3


Connector #3
Connector Name : CN3

-------------------------------------------------------------------
Lane Information
-------------------------------------------------------------------
Lane #0
Channel ID : 0
Device ID : 12
SAS Address : 50000D1107017080
PHY Identifier : 17
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #0

Lane #1
Channel ID : 0
Device ID : 13
SAS Address : 50000D1107017080
PHY Identifier : 18
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #1

Lane #2
Channel ID : 0
Device ID : 14
SAS Address : 50000D1107017080
PHY Identifier : 16
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #2

Lane #3
Channel ID : 0
Device ID : 15
SAS Address : 50000D1107017080
PHY Identifier : 19
----------------------------------------------------------------
Lane SAS Phy Information
----------------------------------------------------------------
No SAS Phy information available for lane #3



Command completed successfully.
 

bonox

Member
Feb 23, 2021
66
15
8
without bothering to read the detailed user guide, that adaptec card appears to be RAID.

What's the bet the disks that don't show up have 520 byte sectors and the card doesn't recognise them?

The shelf is naturally "JBOD/RAW" - that arrangement is all down to the controller you attach them to. Try a vanilla HBA and see if they show, at which point you can check their sector status and reformat them if necessary.

this
suggests you might be able to turn to HBA using the card's own firmware, however there's some other posts that say the card might list 520byte drives but won't let you do anything with them, so probably pointless anyway. Find an LSI HBA instead.

It's also possible that the shelf and/or interposers are defective but from my experience of many of them they seem pretty bulletproof.

Last possible is that the drives have a 3.3V problem, but given their age, i severely doubt this.
 
Last edited:

Sean Ho

seanho.com
Nov 19, 2019
412
165
43
Vancouver, BC
seanho.com
The Adaptec should work just fine; update firmware and flip it to HBA mode in the config (Ctrl-A at the bios option rom prompt, or use arcconf SETCONTROLLERMODE 1 2 from OS). The drives not showing up in arcconf is a problem, though. Sector size conversion is a separate issue; once you can see the /dev/sgX device you can use sg_format to reformat (wiping data in the process).
 
Last edited:

bob_dvb

Active Member
Sep 7, 2018
171
74
28
Not quite London
www.orbit.me.uk
Last night I checked and swapped one of the 2TB Constellation drives for a Seagate Ironwolf, new out of the box, and the caddy/interposer was still orange and blue light flashing occasionally. Reading the installation manual it seems that indicates "fault, drive spinning" but that's all I've got.

I seem to have the same symptoms as @fhturner on here: https://forums.servethehome.com/index.php?threads/emc-ktn-stl3-with-areca-arc-1680ix-8.25935/
But I don't know if it's possible to change the messaging on the Adaptec 71605 that I have?

I've also tried a different interposer, that just has fault and no flashing indicator.
 

bob_dvb

Active Member
Sep 7, 2018
171
74
28
Not quite London
www.orbit.me.uk
Okay, I am really starting to get peeved now.

So I bought an LSI 9285cv-8e to see if that works, and changing one of the interposers it then showed one of the SATA drives. But because the 9285 doesn't have an IT mode and I didn't have the time to reflash it, I bought a 9207-8e which claims to be pre-flashed with IT mode.

However the 9207-8e seems to cause really nasty behaviour, when the enclosure is attached it sticks at boot forever, "Initialising..." With a spinning ASCII animation. Removing the enclosure then just took a while to boot and then the Adaptec 71605 that's already in the system refused to show any drives.

I removed the 9207 and my Proxmox machine behaved itself again!?! I've read that some LSI cards can take several minutes to boot when they have the MPT BIOS flashed, but in this case I waited probably close to an hour with no boot.

I am now so peeved with this enclosure, I have waaay too many HBAs now. I can't keep rebooting my Proxmox machine because it serves a purpose. Perhaps what I need to do is use another machine to help me find what works and then transpose that into the Proxmox server once something works. But I don't really have a spare server class system!

Does anyone know why having an Adaptec 71605 and an LSI 9207 in the same machine would cause issues?

Perhaps I could go back to the 9286cv and use IR to create a RAID array, but I've long been warned off hardware RAID.
 

bonox

Member
Feb 23, 2021
66
15
8
it's possible that the expander or something else in the box/cable/etc has a hardware error. These issues are the price you pay for unsupported configuration usage of old SAN equipment.
 

amalurk

Active Member
Dec 16, 2016
275
97
28
100
Typo for KTN-STL3? or how is KNX model different?

Since only the SAS drives are working maybe all the trays/interposers are SAS only. I have a KTN-STL3 that I bought on ebay that was advertised as SATA. Two of the drives weren't working and it turned out on closer examination that the seller had included two trays with interposers that were SAS only. Once I got two more SATA compatible ones all drives worked.