Does W10 Pro have a network usage limitation per core?

Discussion in 'Networking' started by XtraLimit, Apr 15, 2019.

  1. XtraLimit

    XtraLimit New Member

    Joined:
    Apr 15, 2019
    Messages:
    5
    Likes Received:
    0
    Hello!

    Not sure am i in right place to ask this or should i have done this in software side..

    So the issue is that i got dual xeon setup of 2 x 2680v2s and couple of intels x540-t2 10 gbit network cards.. so i have juice for networking i guess but issue itself is that windows dosnt utilize more than one logical core out of 40 when moving stuff heavily between 2 pcs.. mostly same core than windows itself uses what causes longer term 100% usage for just one core and server crashes..

    I have been reading alot from google and forums.. changing lots of settings in nic settings aswell but nothing seems to help in this issue..

    Does any1 have experience in this kind of matter to make network and or windows to make use more cores for this? I have all cores allowed for windows from msconfig settings.. or is this somekind of limit in windows 10 pro and i would need somekind of datacenter edition or some other higher end windows to get rid of this issue? i dont like to have my server crashing when moving stuff not even that hard..

    Anykind of direction for this matter or even smallest help is appriciated!

    /X
     
    #1
  2. Evan

    Evan Well-Known Member

    Joined:
    Jan 6, 2016
    Messages:
    2,805
    Likes Received:
    407
    The issue is not windows 10, but I guess your using explorer to copy the data ? You need to use a multi threaded application to do the copy so you use more than one core.

    robocopy with the /MT option should do it.
     
    #2
  3. XtraLimit

    XtraLimit New Member

    Joined:
    Apr 15, 2019
    Messages:
    5
    Likes Received:
    0
    Thanks for the reply! (^^,)

    Yes i do use exploder in WIN.. gotta try that robocopy thingy.. wierd tho that windows itselft in these days cant do such thing itself? :eek: Like use more available cores..
    I guess qtorrent usest same exploder base when moving via network so it also gives a bit issue..

    One thing tho is that when i do speedtest with firefox and chrome, it is pretty much only one (ish) core what both uses when measuring and around one core only goes to higher levels.. FF is x64 and Chrome is x64 aswell so those atleast supports memory space but cpu is still limited? from task manager all cores are allowed
     
    #3
  4. cesmith9999

    cesmith9999 Well-Known Member

    Joined:
    Mar 26, 2013
    Messages:
    1,095
    Likes Received:
    333
    also make sure that you validate your RSS settings... and that they are set correctly.

    Chris
     
    #4
  5. XtraLimit

    XtraLimit New Member

    Joined:
    Apr 15, 2019
    Messages:
    5
    Likes Received:
    0
    Hello!

    And really sorry for really late answer.. Too much work and stuff to do :/

    So.. What i have seen in this case trying out for different things, i tryed that robocopy.. i didnt see any help with that.. dont know why tho.. and because it was command line based, it was a bit harder for my usage because larger amount of data at that time..

    Other softs/things i tested is teracopy and richcopy 4.0, didnt see much problem solving with these softs eather so issue is prolly in somewhere else?

    Same thing goes does matter wich way transfer is going.. do i read from server or do i write to server.. it is only 1 core/thread that is used and it is same what windows uses and longer period of time it gets abused 100%, only that one core, windows crashes..

    I have stablebit drivepool installed with raid0 cache ssd system with 2 x 860s.. + couple normal network shared basic hdds without pooling..

    My RSS settings are 16 Queus at both ends.. In this PC i have i7 930 @ 3.8 Ghz and other side i have dually xeon 2860 v2s so i guess atleast i have some juice to give for that option?

    I also have Asus XG-U2008 switch between server and this pc..

    Jumbos are used aswell..

    930 pc has a Winblows 7 ultimate x64 and server has W10 Pro x64 if there is any help with that info..?

    /X
     
    #5
  6. TRACKER

    TRACKER New Member

    Joined:
    Jan 14, 2019
    Messages:
    23
    Likes Received:
    5
    Hello,
    regarding the switch, I had Asus XG-U2008 and returned it, as it was overheating like hell.
    Lots of problems with that switch and Asus XG-C100C/Intel X540-T2.
     
    #6
  7. XtraLimit

    XtraLimit New Member

    Joined:
    Apr 15, 2019
    Messages:
    5
    Likes Received:
    0

    Yea i read about those heating issues and dropped first one 120mm fan and now there is 2x120mm fans blowing from under.. i hot clued those fans to its bottom.. should stay cool.. and i dont have that much abusing for 10 gbit connection between these 2, pc and server because something throthles hard and i cant figure out what.. that one core goes around 100% after i use network around as 1 gbit, some over 100 mb/s speeds.. cant get faster speeds for some reason and neather more core usage..
     
    #7

Share This Page