Can't get Truenas to boot off USB on UEFI BIOS

Feb 21, 2022
32
4
8
I'm stumped on what I am doing wrong. I wanted to try Truenas on a newer machine. It is an HP Elitedesk 800 G3. I can't get it to boot off my USB drive, and I can't get the BIOS to stay in legacy mode. I've tried using Rufus and Balena Etcher to make a 12.0-U8 USB drive. Tried the drive in a Lenovo M73 with UEFI enabled and it fails to boot off it also. I am under the impression that Turenas is UEFI compatible. I see some people in forums saying they use UEFI boot, but I can't find any information on what they did to make it work. Any suggestions on what I am doing wrong?
 

AiC

New Member
Oct 28, 2018
19
9
3
Are you just trying to install it and having problems? If you are using a USB 3.0 port that may be your problem. Try a 2.0 port
 
  • Like
Reactions: What_Is_Computer
Feb 21, 2022
32
4
8
Are you just trying to install it and having problems? If you are using a USB 3.0 port that may be your problem. Try a 2.0 port
I'm using a USB 2.0 flash drive. Tried USB 2.0 and 3.0 ports. The PCs won't boot the drive if in UEFI mode. I know the drive works because if I disable UEFI on the lenovo it will boot just fine.
 

Sean Ho

seanho.com
Nov 19, 2019
509
202
43
Vancouver, BC
seanho.com
From your BIOS boot list, are you selecting the USB drive to be booted in UEFI mode, not BIOS mode? The same USB drive can be booted in either mode. From EFI shell, does map show the USB drive? If so, can you change to that drive and run its efi executable?
 

Markess

Well-Known Member
May 19, 2018
987
648
93
I just reinstalled the other day. On my system, to successfully boot off the installation USB in UEFI mode, I had to pick the 2nd partition on the USB stick.