Brocade VDX 6740

klui

Active Member
Feb 3, 2019
533
236
43
None of my passive copper DACs work on mine. Of AOCs I have access to a Mellanox AOC works but not Intel OmniPath. I don't have AOC breakouts.
 

mbze430

Member
Nov 1, 2019
37
2
8
I just tried some CISCO-MERAKIs DAC cables and they don't work either. So the only way is to get AOC or tranciever and optic cables?

2021/12/21-17:57:37, [NSM-1042], 1656, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:57:49, [NSM-1042], 1662, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:58:14, [NSM-1042], 1667, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:58:51, [NSM-1042], 1674, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:58:51, [NSM-1042], 1675, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:59:29, [NSM-1042], 1685, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:59:29, [NSM-1042], 1686, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:59:37, [NSM-1042], 1696, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:59:37, [NSM-1042], 1697, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-18:00:04, [NSM-1042], 1706, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-18:00:39, [NSM-1042], 1712, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.

 

thefloyd

New Member
Dec 21, 2020
25
5
3
I just tried some CISCO-MERAKIs DAC cables and they don't work either. So the only way is to get AOC or tranciever and optic cables?

2021/12/21-17:57:37, [NSM-1042], 1656, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:57:49, [NSM-1042], 1662, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:58:14, [NSM-1042], 1667, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:58:51, [NSM-1042], 1674, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:58:51, [NSM-1042], 1675, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:59:29, [NSM-1042], 1685, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:59:29, [NSM-1042], 1686, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-17:59:37, [NSM-1042], 1696, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-17:59:37, [NSM-1042], 1697, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/49 is detected.
2021/12/21-18:00:04, [NSM-1042], 1706, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
2021/12/21-18:00:39, [NSM-1042], 1712, SW/0 | Active | DCE, WARNING, sw0, Unqua lified SFP transceiver for interface FortyGigabitEthernet 1/0/50 is detected.
As that message says, it’s a warning. I use all sorts of “unqualified” transceivers with my VDX switches. Have you tested to see if they actually work?
 
  • Like
Reactions: klui

klui

Active Member
Feb 3, 2019
533
236
43
Yup, the clue doesn't come form sh log raslog | inc interface but instead sh log raslog | inc fo0 but poster never included those entries.
 

mbze430

Member
Nov 1, 2019
37
2
8
As that message says, it’s a warning. I use all sorts of “unqualified” transceivers with my VDX switches. Have you tested to see if they actually work?
yeah it negotiate for a bit and then it just shuts off. when you do a sh int status and it say it's admindown. My Celestica DX010 link lights goes off and the VDX shows a amber blinker

UPDATE: It is working. I initially tried to set port 1/0/49 & 50 as LACP Uplink. But when I put it in a regular non-configured port it is staying up. So my skill in setting up a LACP on the VDX is the problem.

@fohdeesha

You seems to be all expert on these VDX and other Brocade/Extreme Network switches. Any thing you can recommend?
 
Last edited:

thefloyd

New Member
Dec 21, 2020
25
5
3
yeah it negotiate for a bit and then it just shuts off. when you do a sh int status and it say it's admindown. My Celestica DX010 link lights goes off and the VDX shows a amber blinker

@fohdeesha

You seems to be all expert on these VDX and other Brocade/Extreme Network switches. Any thing you can recommend?
sounds like something on the celestica end TBH because my VDX switches aren’t at all picky about DACs and/or optics.
 

mbze430

Member
Nov 1, 2019
37
2
8
sounds like something on the celestica end TBH because my VDX switches aren’t at all picky about DACs and/or optics.
It is working. I initially tried to set port 1/0/49 & 50 as LACP Uplink. But when I put it in a regular non-configured port it is staying up. So my skill in setting up a LACP on the VDX is the problem.

I think I need to revisit on how to set up a port-channel LACP
 

thefloyd

New Member
Dec 21, 2020
25
5
3
It is working. I initially tried to set port 1/0/49 & 50 as LACP Uplink. But when I put it in a regular non-configured port it is staying up. So my skill in setting up a LACP on the VDX is the problem.

I think I need to revisit on how to set up a port-channel LACP
This is how I have 2 of my breakout interfaces (40->4x10) configured to uplink to another switch:

interface TenGigabitEthernet 1/0/36:3
channel-group 1 mode active type standard
no fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown
!
interface TenGigabitEthernet 1/0/36:4
channel-group 1 mode active type standard
no fabric isl enable
fabric trunk enable
lacp timeout long
no shutdown
!

interface Port-channel 1
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
no switchport trunk tag native-vlan
no spanning-tree shutdown
no shutdown
!

Note that I haven't spent much time learning about the fabric stuff yet and some of those settings are the defaults the switch imposed when I started configuring so I can't promise this is the *best* config, but I can attest that this works for LACP of 2 interfaces from the VDX to an icx7250.
 

mbze430

Member
Nov 1, 2019
37
2
8
this is mine
interface FortyGigabitEthernet 1/0/49
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout long
no shutdown
!
interface FortyGigabitEthernet 1/0/50
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout long
no shutdown
!
interface Port-channel 1
vlag ignore-split
mtu 9100
description Uplink to DX010
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk allowed vlan remove 1
switchport trunk tag native-vlan
no spanning-tree shutdown
no shutdown

There is something of a question here. Since I am bonding 2x40Gbps which makes 80Gbps... the "speed" setting doesn't give that option

sw0(config-Port-channel-1)# speed ?
Possible completions:
[10000]
100 100Mbps
1000 1Gbps
10000 10Gbps
40000 40Gbps
100000 100Gbps
sw0(config-Port-channel-1)# speed
 
Last edited:

thefloyd

New Member
Dec 21, 2020
25
5
3
this is mine
interface FortyGigabitEthernet 1/0/49
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout long
no shutdown
!
interface FortyGigabitEthernet 1/0/50
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout long
no shutdown
!
interface Port-channel 1
vlag ignore-split
mtu 9100
description Uplink to DX010
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk allowed vlan remove 1
switchport trunk tag native-vlan
no spanning-tree shutdown
no shutdown

There is something of a question here. Since I am bonding 2x40Gbps which makes 80Gbps... the "speed" setting doesn't give that option

sw0(config-Port-channel-1)# speed ?
Possible completions:
[10000]
100 100Mbps
1000 1Gbps
10000 10Gbps
40000 40Gbps
100000 100Gbps
sw0(config-Port-channel-1)# speed
Think the 'speed' is the per interface speed. I get the same from my port-channels:

sw0(config-Port-channel-1)# speed ?
Possible completions:
[10000]
100 100Mbps
1000 1Gbps
10000 10Gbps
40000 40Gbps
100000 100Gbps
sw0(config-Port-channel-1)# exit

but a show interface shows the aggregate speed:

sw0# show interface port-channel 1
Port-channel 1 is up, line protocol is up
Hardware is AGGREGATE, address is c4f5.7c40.96e5
Current address is c4f5.7c40.96e5
Interface index (ifindex) is 671088641
Minimum number of links to bring Port-channel up is 1
MTU 2500 bytes
LineSpeed Actual : 20000 Mbit
Allowed Member Speed : 10000 Mbit
Priority Tag disable
Last clearing of show interface counters: 3w6d13h
Queueing strategy: fifo
Receive Statistics:
888142460 packets, 654997139866 bytes
Unicasts: 462647212, Multicasts: 16542540, Broadcasts: 408952702
64-byte pkts: 13025268, Over 64-byte pkts: 444989632, Over 127-byte pkts: 8510448
Over 255-byte pkts: 7326167, Over 511-byte pkts: 11298897, Over 1023-byte pkts: 378503282
Over 1518-byte pkts(Jumbo): 24488766
Runts: 0, Jabbers: 0, CRC: 0, Overruns: 0
Errors: 6, Discards: 0
Transmit Statistics:
310671033 packets, 333470671777 bytes
Unicasts: 305896168, Multicasts: 2687801, Broadcasts: 2087064
Underruns: 0
Errors: 0, Discards: 0
Rate info:
Input 0.183712 Mbits/sec, 47 packets/sec, 0.00% of line-rate
Output 1.367480 Mbits/sec, 166 packets/sec, 0.01% of line-rate
Time since last interface status change: 3w6d12h

sw0#
 

mbze430

Member
Nov 1, 2019
37
2
8
I am remote right now to physically attach the second cable but will try setting the port-channel speed to 40000 and hopefully makes a connection.
sw0(config-Port-channel-1)# do show running-config interface Port-channel 1
interface Port-channel 1
vlag ignore-split
speed 40000
mtu 9100
description Uplink to DX010
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk allowed vlan remove 1
switchport trunk tag native-vlan
spanning-tree shutdown
no shutdown
!
There isn't much on the Celestica side as it runs SONiC
Port Channels - Link Aggregation - LAG | SONiC 202012 (nvidia.com)
 
Last edited:

mbze430

Member
Nov 1, 2019
37
2
8
woot the port channel works now. However the 2nd cable I have is actually bad but all is well with redundancy :)
 

mbze430

Member
Nov 1, 2019
37
2
8
alright I need more help...
I am trying to setup in-bound management so I don't need a cable connected the management port on the VDX.
I have been using these examples:
How to configure management port in VDX 6740? : Brocade (reddit.com)
Q A: How to configure in-bound management for VDX platform in two-node VCS thru VE interface? | Extreme Portal (force.com)

but once again I am failing

Here are my setup
sw0# show running-config rbridge-id interface
rbridge-id 1
interface Ve 254
ip proxy-arp
ip address 10.0.254.13/24
no shutdown
sw0(conf-if-fo-1/0/52)# do show vlan brief
Total Number of VLANs configured : 3
Total Number of VLANs provisioned : 3
Total Number of VLANs unprovisioned : 0
VLAN Name State Ports Classification
(F)-FCoE (u)-Untagged
(R)-RSPAN (c)-Converged
(T)-TRANSPARENT (t)-Tagged
================ =============== ========================== =============== ====================
1 default INACTIVE(no member port)

254 VLAN0254 ACTIVE Po 1(t)

1000 VLAN1000 ACTIVE Po 1(u)
Te 1/0/47(u)
Te 1/0/48(u)
Te 1/0/45(u)
Te 1/0/43(u)
sw0# show arp
Entries in VRF default-vrf : 1
Address Mac-address L3 Interface L2 Interface Age Type
--------------------------------------------------------------------------------
10.0.254.254 00e0.ec8a.1abb Ve 254 Po 1 00:01:23 Dynamic

as you can see I am using my port channel as the "management port" (unless it doesn't work this way and needs a physical port?)
VLAN254 is my networkwide vlan for everything that is consider to access management port. Currently the management port has 10.0.254.3.
show arp does see my VLAN254 gateway.
 
Last edited:

Derwood

Member
May 22, 2019
52
1
8
Do you folks mind if I tag along with this thread too & contribute if possible, I've an VDX 6740T & VDX 6720 linked via QSFP+ > 4x SFP+ DAC :D

*SO surprised not to see you folks running chasing LED scripts ;)
 

Derwood

Member
May 22, 2019
52
1
8
Hello STH,

I have recently bought 2 VDX6740 switches from a company that was being liquidated. They were never deployed and were brand new. I was wondering if anyone had any experience with these switches. I plan to use upto 10 ports for fiber connectivity across my servers and desktops in a homelab environment . I had few questions and I would be really thankful if someone helped me out with them.

  1. Is there anything specific about this switch that I should know of?

  2. Will non-brocade SFP+ transceivers work?
  3. Is there any chance of unlocking all of the 48 ports and 4 QSFP ports? My switches appear to have come with only 24 SFP+ ports activated by the base license and none of the QSFP ports activated.
Heya,

Amazing to see other users of these branded switch models, my attraction which grew from another home lab technician's nod on a good purchase which was the VDX6720 which seemed an easy jump from an aging Netgear GS748TS stack @ 1GbE per port to 10GbE linking the servers however this sole purchase did limit me to two avenues either everything is going 10GbE right up to the router or we're basically media converting.

I also had further notions because I already have an Infiniband QDR 40GbE/10GbE Ethernet fabric laid which is based on the Voltaire GridDirector 4036 so I was seeking to connect my DAS server and storage array's directly to the ethernet LAN and at 40GbE via the QSFP+ socket of which I have four and two enabled presently. One for interlinking the two VDX switches over a DAC and the other port is destined for the DAS.

I have to say in reply to question 1.: If a purchaser is thinking it's a nice trade-up with fancy web GUI's and plenty of public assistance to call upon, honestly and no disrespect but don't bother. However understanding the framework and usage of in a homelab environment if you are really interested about running operations, hardware like this is an amazing educational experience and once a bit more comfortable with quite a pleasure to administer.

3: Will non-brocade SFP+ transceivers work. I'm not 100% sure totally but my DAC cable [1xQSFP+ > 4x SFP+] is listed Juniper compatible and I've never had an issue, if that at all helps and I'm further attempting NetApp branded QSFP+ cables to lead from the VDX6740 to computer server nodes.

-It should end-up that my four QSFP+ ports on the VDX6740 lead in a pattern like this:
Port 0: QSFP+ > 4x SFP+ VDX6720,
Port 1: QSFP+ > QSFP+ DAS,
Port 2: QSFP+ > QSFP+ Large compute node1,
Port 3: QSFP+ > QSFP+ Large compute node2.

4: Is the best question of all, yes you can upgrade these switches as you know but that does depend somewhat sometimes to the total end maximum configuration you can obtain but yes you can and I can assist you with licensing of some models and obtaining whatever the maximum level obtainable to that variant through a seller online and at really great prices, -I've tried my best to keep in contact with them regarding further sales too simply because they are so hard to find and they've not objected at all to finding a solution.

The VDX6740 came with 48 RJ45 ports @1GbE and with two active QSFP+ @ 40GbE.
Kind regards,

P.S: I've some documents here: All the things -If you'd like to add anything too, that's kewl :)
 
Last edited:

Chow

New Member
Mar 15, 2022
7
0
1
Hi Guys :)

I have a little Question to the License. I have bought an Brocade VDX6740-24.

I don´t know the exactly meaning of the output of "show license" and "show dpod".

Here is the output.

Code:
# show license

switch-id: 2
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
       10G Port Upgrade license
       Feature name:PORT_10G_UPGRADE
       License is valid
       Capacity: 16
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
       40G Port Upgrade license
       Feature name:PORT_40G_UPGRADE
       License is valid
       Capacity: 4
Code:
show dpod
switch-id: 2
   48 10G ports are available in this switch
    4 40G ports are available in this switch
   10G Port Upgrade license is installed
   40G Port Upgrade license is installed
     Dynamic POD method is in use

  40 10G port assignments are provisioned for use in this switch:
        24 10G port assignments are provisioned by the base switch license
        16 10G port assignments are provisioned by the 10G Port Upgrade license
  14 10G ports are assigned to installed licenses:
        14 10G ports are assigned to the base switch license
         0 10G ports are assigned to the 10G Port Upgrade license
  10G ports assigned to the base switch license:
     2/0/1, 2/0/2, 2/0/3, 2/0/4, 2/0/5, 2/0/17, 2/0/18, 2/0/19, 2/0/20, 2/0/21
     2/0/45, 2/0/46, 2/0/47, 2/0/48
  10G ports assigned to the 10G Port Upgrade license:
     None
  10G ports not assigned to a license:
     2/0/6, 2/0/7, 2/0/8, 2/0/9, 2/0/10, 2/0/11, 2/0/12, 2/0/13, 2/0/14, 2/0/15
     2/0/16, 2/0/22, 2/0/23, 2/0/24, 2/0/25, 2/0/26, 2/0/27, 2/0/28, 2/0/29, 2/0/30
     2/0/31, 2/0/32, 2/0/33, 2/0/34, 2/0/35, 2/0/36, 2/0/37, 2/0/38, 2/0/39, 2/0/40
     2/0/41, 2/0/42, 2/0/43, 2/0/44
  26 license reservations are still available for use by unassigned ports

   4 40G port assignments are provisioned for use in this switch:
         0 40G port assignments are provisioned by the base switch license
         4 40G port assignments are provisioned by the 40G Port Upgrade license
   4 40G ports are assigned to installed licenses:
         0 40G ports are assigned to the base switch license
         4 40G ports are assigned to the 40G Port Upgrade license
  40G ports assigned to the base switch license:
     None
  40G ports assigned to the 40G Port Upgrade license:
     2/0/49, 2/0/50, 2/0/51, 2/0/52
  40G ports not assigned to a license:
     None
   0 license reservations are still available for use by unassigned ports
Does this mean, from 24 Ports are 16 for 10Gbit and also all 4 QSFTP Ports are licensed for 40 Gbit, yes?

Or does this mean 16 Ports @ 10 Gbit and 24 Ports @ 1Gbit too?

Why does a VDX6740-24 with normaly 24 Ports show 48 / 40 Ports? Can i license this 24 Port one to full 48 Ports? The Hardware is in the switch?

Thanks for your help :) I'am new at Brocade - sorry for the i think stupid question :D
 

thefloyd

New Member
Dec 21, 2020
25
5
3
40 10G port assignments are provisioned for use in this switch:
the switch has 40 licensed 10gb ports as per the above. It came with 24 and someone licensed 16 more.

all 4 40gig ports are licensed too, due to the similar message about the 40gb ports with the text referencing the 40gb upgrade license being installed underneath that.

The switch uses dynamic port licensing so *any* 40 10gb ports can be in use simultaneously.
 
  • Like
Reactions: Jason Antes

Chow

New Member
Mar 15, 2022
7
0
1
Thanks for your answer theflouyd ;-)

A ok - i thought the "base switch license" are only 1 GbE Ports and not 10 GbE Ports?!