Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

itronin

Well-Known Member
Nov 24, 2018
1,234
794
113
Denver, Colorado
...
However anything that tries to connect to the WiFi's that are set up to use VLAN 10 or VLAN 100 gets stuck on just "connecting" so obviously there's some config missing in the switch but I don't really know what to do here?
If the config is as bare bones as you state then you have not set up in your switch for the other two vlans you have defined in your Omada WiFi: 10 and 100. you need to set those up in the switch. You'll need to tag the AP connected ports in your switch with 10 and 100. Not knowing anything about what Omada expects I suspect you'll keep vlan 1 untagged which means dual-mode on those ports otherwise if your AP's are statically configured for vlan and IP then you may simply need add vlan 1 as tagged on your AP connected ports.
 

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
Remote command to ICX fastiron switch possible?

Hello,
is there a simple way to place remote commands to an ICX fast iron switch via shell script or REST API? What I would like to achieve is to switch off and on PoE on specific ports of my ICX 7150 via home automation to shutdown PoE WiFi APs when not needed.
 

kapone

Well-Known Member
May 23, 2015
1,095
642
113
Remote command to ICX fastiron switch possible?

Hello,
is there a simple way to place remote commands to an ICX fast iron switch via shell script or REST API? What I would like to achieve is to switch off and on PoE on specific ports of my ICX 7150 via home automation to shutdown PoE WiFi APs when not needed.
ssh
 
  • Like
Reactions: noduck

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
Meanwhile I found out about RESTCONF, a possibility to read and set the config by xml or json formated input.

This looks easy to implement. Unfortunately I did not yet figure out how how to use. If someone could let me know the line to issue "no inline power" and "inline power" for a specific network port, let's say 1/1/1, would be great.

Edit:
I am getting close. I already can read the status. This line
Code:
curl -i -k -X "GET" https://192.168.x.y/restconf/data/openconfig-interfaces:interfaces/interface=ethernet%201%2F1%2F1/ethernet/poe/config/enabled -u user:password --insecure
will get me this output
Code:
{"icx-openconfig-if-poe-aug:enabled":true}
Now I only have to find out how to chenge the value.
 
Last edited:
  • Like
Reactions: noduck

MannyLNJ

New Member
Mar 19, 2023
22
9
3
Hello. I am not sure now if I ordered the right items. My home network is all 1GB products but I am slowly adding 2.5GB devices. Right now my PC and my OpnSense system both supoort 2.5G. I bought a Brocade FCX648S-HPOE 48 on Ebay along with a Brocade ES46625M-FLF-08 2x 10GB XFP Switch Modile. I know the fans may be loud but I have all my network gear in the basement and while I do sit near the shelves. I can move it to the other side of the basement if I have power ran. From what I understand if I have the right transceiver I can turn the switch interconnects in the back into 2.5G ports is that correct? If not what should I buy?
 

Mithril

Active Member
Sep 13, 2019
354
106
43
Anyone know the pinout for the EPS cable? I picked up An ICX6400-EPS1500 for cheap, but the cables are not cheap :( The connector is a standard computer power supply (20 pin). Looks like the EPS1500 effectively is in low power mode unless theres a cable connected so I can't even test what I purchased :(

Edit:[Found in thread!]
 

Mithril

Active Member
Sep 13, 2019
354
106
43
If anyone wants a pinout for the DC cable to power 64XX switches with an ICX6400-EPS1500

Code:
WST Coonnectors P20-I42002 (ATX V1, MiniFit Jr 1727080020 etc.)

Pins are straight through, connection 1 on one end goes to connection 1 on the other end.

Cable including connectors is 1M long.

Viewed from the switch or psu side. Retaining clip at top.

______________===______________
|11|12|13|14|15|16|17|18|19|20|
|01|02|03|04|05|06|07|08|09|10|

1-5,11-15 : 18AWG 300V insulated wire.
______________===______________
|11|12|13|14|15|  |  |  |  |  |
|01|02|03|04|05|  |  |  |  |  |

7-10,17-19 : 7 Conductor Unshielded Cable, 18AWG 300V insulated wire. Like Belden 8467MN. These may be the 54v PoE wires.
______________===______________
|  |  |  |  |  |  |17|18|19|  |
|  |  |  |  |  |  |07|08|09|10|

6,16,20 : Empty
______________===______________
|  |  |  |  |  |16|  |  |  |20|
|  |  |  |  |  |06|  |  |  |  |
Oh thank sweet [censored] this is what I'm looking for! TY!!!
 

Cirdane

New Member
Mar 18, 2023
3
1
3
If the config is as bare bones as you state then you have not set up in your switch for the other two vlans you have defined in your Omada WiFi: 10 and 100. you need to set those up in the switch. You'll need to tag the AP connected ports in your switch with 10 and 100. Not knowing anything about what Omada expects I suspect you'll keep vlan 1 untagged which means dual-mode on those ports otherwise if your AP's are statically configured for vlan and IP then you may simply need add vlan 1 as tagged on your AP connected ports.
Thank you, I managed to find some documentation on how dual-mode works and that did the trick :)
 
  • Like
Reactions: itronin

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
Thank you. Meanwhile I got it.
The TN is what I have used to figure out how to use the the restconf. I am not an expert in this. So I had use a little bit trial and error to get the right formating of the required input values.

Finally this did the trick:
Code:
curl -vX "PUT" -d @"input.json" --header "Content-Type: application/yang-data+json" https://192.168.x.y/restconf/data/openconfig-interfaces:interfaces/interface=ethernet%201%2F1%2F1/ethernet/poe/config/enabled -u user:password --insecure
With this as input file:
JSON:
{"icx-openconfig-if-poe-aug:enabled":false}
I was not able to include the json input in the code for the command line, but this is fine. In the automation I can separate the input.

I would think remote ssh would be more straightforward.
Depends. If you want do do something manually, yes. For automation a single command is easier to handle. Error handling also is easier. SNMP would be another option. But so far I did not yet checked what will be easier to handle by Home Assistant: restconf or snmp?
 

klui

Well-Known Member
Feb 3, 2019
824
453
63
curl .... -d ${JSON} ....

i.e.: curl .... -d '{ "icx-....": false}' ....

The problem with SNMP and Restconf is the commands are too different from the switch's CLI and while you can use Restconf there's no guarantee all parameters are configurable using it. I've never tried to decipher configuring network devices using SNMP. For more straightforward switch automation I prefer something like paramiko.
 
  • Like
Reactions: tubs-ffm

vpadro

New Member
Jul 16, 2015
16
2
3
47
I don't know what I did but I can't get tagged vlans in a working state, ports on 3 different untagged vlans (VLAN50, 51 & 55) get IP from DHCP, DNS, transit VLAN works as expected on a pfsense router, meaning I have internet traffic on those 3 untagged VLANs, but can't get DHCP or Static addressing to reach the other VLANs/Internet on the Server VLAN or the LAN VLAN, maybe some pointers where to look or un-do.

Here's the config:

swrouter01(config-vlan-60)#sh run
Current configuration:
!
ver 09.0.10eT213
!
stack unit 1
module 1 icx7250-48-port-management-module
module 2 icx7250-sfp-plus-8port-80g-module
stack disable
!
!
!
global-stp
!
!
vlan 1 name DEFAULT-VLAN by port
no untagged ethe 1/2/8
spanning-tree
!
vlan 40 name Transit by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 50 name LAN by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/39 ethe 1/1/43 to 1/1/46 ethe 1/2/1 to 1/2/4 ethe 1/2/7 to 1/2/8
untagged ethe 1/1/2 to 1/1/4 ethe 1/1/6 to 1/1/9 ethe 1/1/11 ethe 1/1/13 ethe 1/1/15 to 1/1/17 ethe 1/1/20 to 1/1/21 ethe 1/1/23 ethe 1/1/25 ethe 1/1/27 ethe 1/1/29 ethe 1/1/31 to 1/1/38 ethe 1/1/40 ethe 1/1/47 ethe 1/2/5 to 1/2/6
!
vlan 51 name OOB by port
tagged ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/1 ethe 1/1/5 ethe 1/1/26 ethe 1/1/28 ethe 1/1/30
!
vlan 52 name VoIP by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/39
!
vlan 53 name Guest by port
tagged ethe 1/1/39 to 1/1/40
ip access-group NoPeaking in
!
vlan 54 name IoT by port
tagged ethe 1/1/39 to 1/1/40
ip access-group NoPeaking in
!
vlan 55 name Management by port
tagged ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/14 ethe 1/1/18 ethe 1/1/43 to 1/1/46 ethe 1/1/48 ethe 1/2/1 to 1/2/4
!
vlan 56 name vAppliaces by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 60 name Servers by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/16 ethe 1/1/20 ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/22 ethe 1/1/24
!
vlan 65 name "Dev Servers" by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/16 ethe 1/1/20 ethe 1/1/39 ethe 1/2/7
!
vlan 70 name WFH by port
tagged ethe 1/1/39
untagged ethe 1/1/19
!
vlan 80 name "Dev LAN" by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 81 name "Dev LAN 01" by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 90 name "Storage 01" by port
tagged ethe 1/1/39 ethe 1/2/5 to 1/2/6
!
vlan 91 name "Storage 02" by port
tagged ethe 1/1/39 ethe 1/2/5 to 1/2/6
!
vlan 92 name vMotion by port
tagged ethe 1/1/39 ethe 1/2/1 to 1/2/4
!
vlan 410 name WAN by port
tagged ethe 1/1/39
untagged ethe 1/1/41
!
vlan 420 name WAN1 by port
tagged ethe 1/1/39
untagged ethe 1/1/42
!
!
!
!
!
!
ip route 0.0.0.0/0 192.168.40.1
!
!
clock timezone gmt GMT-06
hostname swrouter01
ip dns domain-list padrosys.net
ip dns server-address 192.168.50.2 192.168.50.3
ip tftp blocksize 8192
!
!
ntp
disable serve
server 192.168.50.4
server 192.168.50.5
!
!
!
!
!
!
!
!
!
interface management 1
!
interface ve 40
ip address 192.168.40.2 255.255.255.248
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 50
ip address 192.168.50.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 51
ip address 192.168.51.1 255.255.255.224
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 52
ip address 192.168.52.1 255.255.255.224
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 53
ip address 10.50.53.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 54
ip address 10.50.54.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 55
ip address 192.168.55.1 255.255.255.128
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 56
ip address 192.168.56.1 255.255.255.128
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 60
ip address 192.168.60.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 65
ip address 192.168.65.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 70
ip address 192.168.70.1 255.255.255.240
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 80
ip address 192.168.80.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 81
ip address 192.168.81.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 90
ip address 192.168.90.1 255.255.255.224
!
interface ve 91
ip address 192.168.91.1 255.255.255.224
!
interface ve 92
ip address 10.10.76.1 255.255.255.224
!
!

ip access-list extended NoPeaking
sequence 10 permit udp any host 192.168.50.2 eq bootps
sequence 20 permit udp any host 192.168.50.2 eq dns
sequence 30 permit udp any host 192.168.50.3 eq bootps
sequence 40 permit udp any host 192.168.50.3 eq dns
sequence 50 deny ip any 10.0.0.0 0.255.255.255
sequence 60 deny ip any 172.16.0.0 0.15.255.255
sequence 70 deny ip any 192.168.0.0 0.0.255.255
sequence 80 permit ip any any
!

!
!



!
!
!
!
username super password .....
username admin password .....
username vpadro password .....
!
aaa authentication login default local
!
aaa authentication web-server default local
!
aaa authentication snmp-server default local
!
ip dhcp-client disable
!


!


!


!
no telnet server
!
snmp-server community 2 Hidden= ro
!
manager disable
manager port-list 987
!
cli timeout 5
!


!


!

end

swrouter01(config-vlan-60)#sh ip route
Total number of IP routes: 17
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
STATIC Codes - v:Inter-VRF
Destination Gateway Port Cost Type Uptime
1 0.0.0.0/0 192.168.40.1 ve 40 1/1 S 11h45m
2 10.10.76.0/27 DIRECT ve 92 0/0 D 11h45m
3 10.50.53.0/26 DIRECT ve 53 0/0 D 11h45m
4 10.50.54.0/26 DIRECT ve 54 0/0 D 11h45m
5 192.168.40.0/29 DIRECT ve 40 0/0 D 11h45m
6 192.168.50.0/24 DIRECT ve 50 0/0 D 11h45m
7 192.168.51.0/27 DIRECT ve 51 0/0 D 11h45m
8 192.168.52.0/27 DIRECT ve 52 0/0 D 11h45m
9 192.168.55.0/25 DIRECT ve 55 0/0 D 11h45m
10 192.168.56.0/25 DIRECT ve 56 0/0 D 11h45m
11 192.168.60.0/24 DIRECT ve 60 0/0 D 11h45m
12 192.168.65.0/24 DIRECT ve 65 0/0 D 11h45m
13 192.168.70.0/28 DIRECT ve 70 0/0 D 11h45m
14 192.168.80.0/26 DIRECT ve 80 0/0 D 11h45m
15 192.168.81.0/26 DIRECT ve 81 0/0 D 11h45m
16 192.168.90.0/27 DIRECT ve 90 0/0 D 11h45m
17 192.168.91.0/27 DIRECT ve 91 0/0 D 11h45m

Thank you.

EDIT: Disregard, did an extended ping and got 1048ms more than a few times, changed the ethernet cable and all good, will leave the post for future references on intervlan routing.
 
Last edited:

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
The problem with SNMP and Restconf is the commands are too different from the switch's CLI and while you can use Restconf there's no guarantee all parameters are configurable using it. I've never tried to decipher configuring network devices using SNMP. For more straightforward switch automation I prefer something like paramiko.
Thank you. I believe that there are good solutions if it comes to full automation or complex remote control. What I want to achieve is to issue a single command for a single function using the functionality the home automation software has build in. Here a simple ssh script, restconf or snmp seems to be the mist straight forward way.

I will try out what I am able to handle in the best way. The options now are on the table.
 

vpadro

New Member
Jul 16, 2015
16
2
3
47
I don't know what I did but I can't get tagged vlans in a working state, ports on 3 different untagged vlans (VLAN50, 51 & 55) get IP from DHCP, DNS, transit VLAN works as expected on a pfsense router, meaning I have internet traffic on those 3 untagged VLANs, but can't get DHCP or Static addressing to reach the other VLANs/Internet on the Server VLAN or the LAN VLAN, maybe some pointers where to look or un-do.

Here's the config:

swrouter01(config-vlan-60)#sh run
Current configuration:
!
ver 09.0.10eT213
!
stack unit 1
module 1 icx7250-48-port-management-module
module 2 icx7250-sfp-plus-8port-80g-module
stack disable
!
!
!
global-stp
!
!
vlan 1 name DEFAULT-VLAN by port
no untagged ethe 1/2/8
spanning-tree
!
vlan 40 name Transit by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 50 name LAN by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/39 ethe 1/1/43 to 1/1/46 ethe 1/2/1 to 1/2/4 ethe 1/2/7 to 1/2/8
untagged ethe 1/1/2 to 1/1/4 ethe 1/1/6 to 1/1/9 ethe 1/1/11 ethe 1/1/13 ethe 1/1/15 to 1/1/17 ethe 1/1/20 to 1/1/21 ethe 1/1/23 ethe 1/1/25 ethe 1/1/27 ethe 1/1/29 ethe 1/1/31 to 1/1/38 ethe 1/1/40 ethe 1/1/47 ethe 1/2/5 to 1/2/6
!
vlan 51 name OOB by port
tagged ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/1 ethe 1/1/5 ethe 1/1/26 ethe 1/1/28 ethe 1/1/30
!
vlan 52 name VoIP by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/39
!
vlan 53 name Guest by port
tagged ethe 1/1/39 to 1/1/40
ip access-group NoPeaking in
!
vlan 54 name IoT by port
tagged ethe 1/1/39 to 1/1/40
ip access-group NoPeaking in
!
vlan 55 name Management by port
tagged ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/14 ethe 1/1/18 ethe 1/1/43 to 1/1/46 ethe 1/1/48 ethe 1/2/1 to 1/2/4
!
vlan 56 name vAppliaces by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 60 name Servers by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/16 ethe 1/1/20 ethe 1/1/39 ethe 1/2/7
untagged ethe 1/1/22 ethe 1/1/24
!
vlan 65 name "Dev Servers" by port
tagged ethe 1/1/10 ethe 1/1/12 ethe 1/1/16 ethe 1/1/20 ethe 1/1/39 ethe 1/2/7
!
vlan 70 name WFH by port
tagged ethe 1/1/39
untagged ethe 1/1/19
!
vlan 80 name "Dev LAN" by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 81 name "Dev LAN 01" by port
tagged ethe 1/1/39 ethe 1/2/7
!
vlan 90 name "Storage 01" by port
tagged ethe 1/1/39 ethe 1/2/5 to 1/2/6
!
vlan 91 name "Storage 02" by port
tagged ethe 1/1/39 ethe 1/2/5 to 1/2/6
!
vlan 92 name vMotion by port
tagged ethe 1/1/39 ethe 1/2/1 to 1/2/4
!
vlan 410 name WAN by port
tagged ethe 1/1/39
untagged ethe 1/1/41
!
vlan 420 name WAN1 by port
tagged ethe 1/1/39
untagged ethe 1/1/42
!
!
!
!
!
!
ip route 0.0.0.0/0 192.168.40.1
!
!
clock timezone gmt GMT-06
hostname swrouter01
ip dns domain-list padrosys.net
ip dns server-address 192.168.50.2 192.168.50.3
ip tftp blocksize 8192
!
!
ntp
disable serve
server 192.168.50.4
server 192.168.50.5
!
!
!
!
!
!
!
!
!
interface management 1
!
interface ve 40
ip address 192.168.40.2 255.255.255.248
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 50
ip address 192.168.50.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 51
ip address 192.168.51.1 255.255.255.224
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 52
ip address 192.168.52.1 255.255.255.224
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 53
ip address 10.50.53.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 54
ip address 10.50.54.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 55
ip address 192.168.55.1 255.255.255.128
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 56
ip address 192.168.56.1 255.255.255.128
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 60
ip address 192.168.60.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 65
ip address 192.168.65.1 255.255.255.0
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 70
ip address 192.168.70.1 255.255.255.240
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 80
ip address 192.168.80.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 81
ip address 192.168.81.1 255.255.255.192
ip helper-address 1 192.168.50.2
ip helper-address 2 192.168.50.3
!
interface ve 90
ip address 192.168.90.1 255.255.255.224
!
interface ve 91
ip address 192.168.91.1 255.255.255.224
!
interface ve 92
ip address 10.10.76.1 255.255.255.224
!
!

ip access-list extended NoPeaking
sequence 10 permit udp any host 192.168.50.2 eq bootps
sequence 20 permit udp any host 192.168.50.2 eq dns
sequence 30 permit udp any host 192.168.50.3 eq bootps
sequence 40 permit udp any host 192.168.50.3 eq dns
sequence 50 deny ip any 10.0.0.0 0.255.255.255
sequence 60 deny ip any 172.16.0.0 0.15.255.255
sequence 70 deny ip any 192.168.0.0 0.0.255.255
sequence 80 permit ip any any
!

!
!



!
!
!
!
username super password .....
username admin password .....
username vpadro password .....
!
aaa authentication login default local
!
aaa authentication web-server default local
!
aaa authentication snmp-server default local
!
ip dhcp-client disable
!


!


!


!
no telnet server
!
snmp-server community 2 Hidden= ro
!
manager disable
manager port-list 987
!
cli timeout 5
!


!


!

end

swrouter01(config-vlan-60)#sh ip route
Total number of IP routes: 17
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
STATIC Codes - v:Inter-VRF
Destination Gateway Port Cost Type Uptime
1 0.0.0.0/0 192.168.40.1 ve 40 1/1 S 11h45m
2 10.10.76.0/27 DIRECT ve 92 0/0 D 11h45m
3 10.50.53.0/26 DIRECT ve 53 0/0 D 11h45m
4 10.50.54.0/26 DIRECT ve 54 0/0 D 11h45m
5 192.168.40.0/29 DIRECT ve 40 0/0 D 11h45m
6 192.168.50.0/24 DIRECT ve 50 0/0 D 11h45m
7 192.168.51.0/27 DIRECT ve 51 0/0 D 11h45m
8 192.168.52.0/27 DIRECT ve 52 0/0 D 11h45m
9 192.168.55.0/25 DIRECT ve 55 0/0 D 11h45m
10 192.168.56.0/25 DIRECT ve 56 0/0 D 11h45m
11 192.168.60.0/24 DIRECT ve 60 0/0 D 11h45m
12 192.168.65.0/24 DIRECT ve 65 0/0 D 11h45m
13 192.168.70.0/28 DIRECT ve 70 0/0 D 11h45m
14 192.168.80.0/26 DIRECT ve 80 0/0 D 11h45m
15 192.168.81.0/26 DIRECT ve 81 0/0 D 11h45m
16 192.168.90.0/27 DIRECT ve 90 0/0 D 11h45m
17 192.168.91.0/27 DIRECT ve 91 0/0 D 11h45m

Thank you.
Diagram:

EDIT: Disregard, did an extended ping and got 1048ms more than a few times, changed the ethernet cable and all good, will leave the post for future references on intervlan routing.
 

Attachments

Last edited:

Dade49

New Member
Mar 26, 2021
7
3
3
I've got a spare Brocade cable (came out of a 7250-24P box) still in its original bag, would be happy to ship it to you for a reasonable price if you are interested. It should work with any USB-DE9 adapter with a male connector (I use a Tripp-Lite adapter because it's what I had on hand).

PM me if interested.
I made an adapter (mini-USB to RJ-45) for the 7250-24P that I just picked up using this post:
https://www.reddit.com/r/Brocade/comments/k25l5u/_/gdukwuk
 

moriel5

New Member
Aug 4, 2019
25
4
3
Well then, after all this time I finally have the necessary tools (at least I think I do) and knowledge to even attempt to connect to my Brocade FCX648-HPOE (picking up an old Cisco 887VA-K9 V2 (the old version) that was thrown out by a local medical center branch has helped in that regard).

Unfortunately, I cannot seem to be able to connect to it, no matter what I do (I was able to connect to the Cisco router without any issues, although I am still struggling to understand how to get it to acknowledge what is connected to it, and not just that something is connected).

I have tried using serial RS232 from my motherboard (started with an ASRock H97M, now with an Asus Z97 Pro Gamer), however have been unsuccessful in connecting to anything with the onboard serial controller (I tried both passthrough and crossover cables), so switched over to CH340G-based USB serial controllers (the USB to RJ-45 patch cable works well with the Cisco router, still need to test the USB to RS232 adapter in conjunction with the crossover cable), however even then I am unable to get any output from the console (I use Picocom, and I have verified that my settings are correct: 9600/N/N/8/1 with /dev/ttyUSB0, as dmesg and ls /dev/ report), whether I try using the front RS232 port pr the rear RJ-45 console port.

It appears as though the switch is working (despite it not serving DHCP) from the LEDs that remain on after initialization (PS1, PS2 and Stack ID 1), so I am really stumped here.
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,728
3,078
113
33
fohdeesha.com
Well then, after all this time I finally have the necessary tools (at least I think I do) and knowledge to even attempt to connect to my Brocade FCX648-HPOE (picking up an old Cisco 887VA-K9 V2 (the old version) that was thrown out by a local medical center branch has helped in that regard).

Unfortunately, I cannot seem to be able to connect to it, no matter what I do (I was able to connect to the Cisco router without any issues, although I am still struggling to understand how to get it to acknowledge what is connected to it, and not just that something is connected).

I have tried using serial RS232 from my motherboard (started with an ASRock H97M, now with an Asus Z97 Pro Gamer), however have been unsuccessful in connecting to anything with the onboard serial controller (I tried both passthrough and crossover cables), so switched over to CH340G-based USB serial controllers (the USB to RJ-45 patch cable works well with the Cisco router, still need to test the USB to RS232 adapter in conjunction with the crossover cable), however even then I am unable to get any output from the console (I use Picocom, and I have verified that my settings are correct: 9600/N/N/8/1 with /dev/ttyUSB0, as dmesg and ls /dev/ report), whether I try using the front RS232 port pr the rear RJ-45 console port.

It appears as though the switch is working (despite it not serving DHCP) from the LEDs that remain on after initialization (PS1, PS2 and Stack ID 1), so I am really stumped here.
there's no rj45 console port on the fcx, that's the ethernet management port. for the front rs232 console port, you need a straight through serial cable. if you just have a usb to db9 serial cable, it will be male, and the rs232 on the fcx is male, so I typically just use a female to female couple (that is straight through, NOT null modem): https://www.amazon.com/WOVTE-Changer-Coupler-Adapter-Connector/dp/B00W7BZ31G/

good luck with the noise :p the poe fcx is the loudest switch I've ever heard
 

moriel5

New Member
Aug 4, 2019
25
4
3
there's no rj45 console port on the fcx, that's the ethernet management port. for the front rs232 console port, you need a straight through serial cable. if you just have a usb to db9 serial cable, it will be male, and the rs232 on the fcx is male, so I typically just use a female to female couple (that is straight through, NOT null modem): https://www.amazon.com/WOVTE-Changer-Coupler-Adapter-Connector/dp/B00W7BZ31G/

good luck with the noise :p the poe fcx is the loudest switch I've ever heard
That is what I had meant. RJ-45 is just the connector.
And thanks for the link, however I already have a female to female RS232 cable, which is what I had attempted to use, would there be any benefit to using a male to female (I also have one like that) or male to male cable with the couplers over what I have already tried?

And thanks, but while noticeably loud, the FCX648-HPOE's PSU fans are nowhere near as loud as what it seems like from the comments here (it certainly drowns completely my desktop's fans, understandably), I could easily sleep with it working right outside my window (and I generally listen to music at levels quiet enough that others can't make out the sounds, so this is not due to bad hearing).
 

moriel5

New Member
Aug 4, 2019
25
4
3
Alright, I have no idea whether I am doing something wrong, or that all of my RS232 hardware is faulty, however I am unable to get any console output with the CH340G USB to RS232 adapter and an RS232 to RJ-45 adapter, even with the Cisco router (the CH340G USB to RJ45 cable is working fine with the same Cisco router, however I am getting no output from the Brocade switch with it).

Add to that the fact that I have never been able to get serial over RS232 working with any hardware (I have successfully used serial over USB directly to contacts on boards, and now to RJ-45), and I have absolutely no idea anymore.
 

Whattteva

New Member
Dec 15, 2022
16
1
3
Update from my earlier post about the loud ICX 6450-48 (NO PoE) fan.

I bought this Sunon fan (MB40201V2) and it's working well and while it's not dead silent, it's a HUGE improvement over the stock fan and I'm pretty happy with it. Thermals still look solid (increase of 3 C). I would like to point out a couple issues for anyone else that may want to attempt this:
  • Fan requires the two outer wires to be swapped to function properly. Without swapping, the fan will both spin very slowly and be detected as "failed" by the switch.
  • The stock screws are too small for the new fan so you must buy new screws. You can either buy really short 10-24 screws or long 8-32 screws + nuts. I opted to go with long 8-32 + nuts since the 10-24 feels very very snug on the fan.
If you don't want the headache of dealing with swapping wires and screws, you can just go buy this fan instead for a more plug'n'play experience for a bit more money.