Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

anomaly

Active Member
Jan 8, 2018
274
62
28
Voltage should be constant, I read @rootwyrm 's interposer firmware and it seems the PWM frequency is 25kHz in the 7450 series. @fohdeesha is not engaging the thread right now, but he probably knows all this / can easily test. If the frequency, etc, is all the same for both 6450 and 7250, then it will be quite easy to write a modified interposer that "translates" the speed mode 2 RPM to slower speeds (while reporting roughly the same to the mainboard).

@rootwyrm put some "overkill" design to work in his HW, I asked him if the BAV99 diodes are really needed, but it won't hurt to have them. The teensy is definitely overkill considering we have ESP32 or plain Atmega if you forego the Wifi, which I am personally not interested in at all (out of caution too).

His code is documented here: icx-fan10-mod/src/main.c at main · rootwyrm/icx-fan10-mod

For 7250/6450 mainboard/chassis fans you need a maximum of 3 digital/PWM GPIOs and 3 digital GPIOs for the tachometer, for each side (fan side and mainboard side) for the three fans, so, 12 GPIOs total, to do it properly. The convenience of using the ESP32 is cost and the architecture for multitasking is already there (FreeRTOS with esp-idf). Arduino IMO is crap, as far as the library/glue code is involved.
 

Dave Corder

Active Member
Dec 21, 2015
325
217
43
42
So, I accidentally bought an ICX7150-C12P on eBay the other day. It was listed "AS-IS" and started at $29.99, so I threw in a $29.99 bid just for kicks, then forgot all about it. No one else wanted to take a chance on it, and I won. It showed up yesterday. There was a dent in the underside of the chassis, at the front near the SFP+ ports that was flexing the PCB. I disassembled it, straightened the chassis it back out as best I could, and put it together.

However, it does appear to be totally dead. No lights or anything when I plug it in, and nothing on the RJ45 console port. I checked the PSU and it is putting out 52V or so, so it doesn't appear to be that common issue.

So it seems like it's a system board issue. Anyone have any ideas on what I can look at or what I might be able to test or repair to get it functional again? I couldn't find a whole lot on system board failures, just PSU failures, when I searched the archives.
 

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
I've got my ICX7250-24P I bought off eBay in Europe. I believe someone already did a fan swap to it, as I've found two delta FFB0412VHN spliced onto the original connectors.

I've tried running the quieter fans I've bought (EFB0412VHD-00), but the asic temp gets way too hot. The airflow at "slow" speed / 4.5V feels at least half of what the fast FFB fans do move. This is a show chassis run after 15 mins of power up, with no interfaces up besides one ethernet for management:

Code:
SSH@ICX7250-24P Router>show chassis
The stack unit 1 chassis info:

Power supply 1 (AC - PoE) present, status ok
Power supply 2 not present

Fan 1 ok, speed (auto): [[1]]<->2
Fan 2 ok, speed (auto): [[1]]<->2

Fan controlled temperature:
        Rule 1/2 (MGMT THERMAL PLANE): 85.6 deg-C
        Rule 2/2 (AIR OUTLET NEAR PSU): 39.5 deg-C

Fan speed switching temperature thresholds:
        Rule 1/2 (MGMT THERMAL PLANE):
                Speed 1: NM<-----> 93       deg-C
                Speed 2:        82<----->105 deg-C (shutdown)
        Rule 2/2 (AIR OUTLET NEAR PSU):
                Speed 1: NM<-----> 58       deg-C
                Speed 2:        49<----->105 deg-C (shutdown)

Fan 1 Air Flow Direction:  Front to Back
Fan 2 Air Flow Direction:  Front to Back
Slot 1 Current Temperature: 85.6 deg-C (Sensor 1), 39.5 deg-C (Sensor 2)
Slot 2 Current Temperature: NA
        Warning level.......: 100.0 deg-C
        Shutdown level......: 105.0 deg-C
I've tried adding a baffle made of thin cardboard to move more air through the ASIC's heatsink, but it only made the temperatures worse, hitting even 88°C on the main chip.

Moving back to the faster fans, the switch stabilized at 36-38°C on the PSU and 81-82°C on the main chip. Tomorrow I might try also with a 60x60x10 fan as some of you did on the asic. I'll be at best at 40W pulled out of the PoE ports, if I can get a balance between temps and noise it would be great.
 

gruntus maximus

New Member
Sep 12, 2024
1
3
3
Registered just to give thanks. First timer, got my 6450-48P based on the activity here - a great set of noob friendly recommendations backed up by an awesomely detailed guide+config documentation+package by fohdeesha. If only 10% of HW guides out there were half as good. Off to tinker!
 

codyjd1

New Member
Sep 7, 2024
3
0
1
Check out the Stacking Guide (fastiron-08030b-switchstackingguide.pdf) from foodesha's package. p46ff explain stacking topologies for ICX6450.

The good news - what you want is supported. Let us know when you got it working.
Awesome thanks for the reply! I will check it out and hope I can get it all configured when they arrive! Thanks again!
 

NablaSquaredG

Bringing 100G switches to homelabs
Aug 17, 2020
1,564
1,010
113
However, it does appear to be totally dead. No lights or anything when I plug it in, and nothing on the RJ45 console port. I checked the PSU and it is putting out 52V or so, so it doesn't appear to be that common issue.
Maybe the onboard voltage regulators that step down 52V to 12V are dead
 

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
Today I've managed to get a 60x60x10 fan, I've tried again running the switch with the smaller fans pushing air out to the back and the dedicated fan on the ASIC, and I've got much better temps. After 2 hours running on a table, with 25°C room ambient air, the ASIC was at 68°C while the PSU area at 40°C. The cooling feels adeguate, provided I don't push the PoE system too much. With these fans installed, my unit pulls 40W during boot and about 50W once it's loaded (with 3 gbe ports up).

Attached a few pics of the mod and also the switch itself.

I've configured a few vlans for all my systems, tomorrow if all goes well I'll put the switch into the network rack into it's definitive working place.
 

Attachments

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
Thanks, that should be fairly easy to find and test with a multimeter.
Could you take a good resolution pic of the main board of the switch? We might be able to give you some more information on where to check for voltages.

The only internal pic I can find is a low resolution 640x480 one.

If you check for voltages after the inductor on the center-left of the pic, do you get anything? That looks to be an insulated main 52 to 12V switcher. Then there are two more converters by the looks of it in the top right part of the board, which could probably be 5/3.3/1.8V supplies. If you get no voltage on any of those rails, also check for shorts (with the switch off) on any of the main mosfets for these rails (soic-8 for the main supply and smaller devices for the others)
 

RoachedCoach

Member
Feb 4, 2020
42
48
18
I've got my ICX7250-24P I bought off eBay in Europe. I believe someone already did a fan swap to it, as I've found two delta FFB0412VHN spliced onto the original connectors.

I've tried running the quieter fans I've bought (EFB0412VHD-00), but the asic temp gets way too hot. The airflow at "slow" speed / 4.5V feels at least half of what the fast FFB fans do move. This is a show chassis run after 15 mins of power up, with no interfaces up besides one ethernet for management:

Code:
SSH@ICX7250-24P Router>show chassis
The stack unit 1 chassis info:

Power supply 1 (AC - PoE) present, status ok
Power supply 2 not present

Fan 1 ok, speed (auto): [[1]]<->2
Fan 2 ok, speed (auto): [[1]]<->2

Fan controlled temperature:
        Rule 1/2 (MGMT THERMAL PLANE): 85.6 deg-C
        Rule 2/2 (AIR OUTLET NEAR PSU): 39.5 deg-C

Fan speed switching temperature thresholds:
        Rule 1/2 (MGMT THERMAL PLANE):
                Speed 1: NM<-----> 93       deg-C
                Speed 2:        82<----->105 deg-C (shutdown)
        Rule 2/2 (AIR OUTLET NEAR PSU):
                Speed 1: NM<-----> 58       deg-C
                Speed 2:        49<----->105 deg-C (shutdown)

Fan 1 Air Flow Direction:  Front to Back
Fan 2 Air Flow Direction:  Front to Back
Slot 1 Current Temperature: 85.6 deg-C (Sensor 1), 39.5 deg-C (Sensor 2)
Slot 2 Current Temperature: NA
        Warning level.......: 100.0 deg-C
        Shutdown level......: 105.0 deg-C
I've tried adding a baffle made of thin cardboard to move more air through the ASIC's heatsink, but it only made the temperatures worse, hitting even 88°C on the main chip.

Moving back to the faster fans, the switch stabilized at 36-38°C on the PSU and 81-82°C on the main chip. Tomorrow I might try also with a 60x60x10 fan as some of you did on the asic. I'll be at best at 40W pulled out of the PoE ports, if I can get a balance between temps and noise it would be great.
I think one of the issues is that those rear fans you put in there are only 10 CFM. That stock ones were around 25, so it's now getting less than half the original air movement.

When I did my mod and used the Mechantronix MR4020X12B1-RSR I think they do well because they're rated at 17.3 CFM. They are a touch louder than the ones you have now, but very reasonable. I also agree the 60mm fan on the ASIC will likely serve you better.

If for some reason you find it still isn't sufficient, one hacky thing you could do is strap a fan externally next to the PSU inlet on the side. I know someone who has it in a closet that did this. It'll provide more airflow explicitly to the PSU (which it seems is actually the first thing to overheat post-mod).
 

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
If for some reason you find it still isn't sufficient, one hacky thing you could do is strap a fan externally next to the PSU inlet on the side. I know someone who has it in a closet that did this. It'll provide more airflow explicitly to the PSU (which it seems is actually the first thing to overheat post-mod).
The main thing with the PSU is that, when running at full power, it's supposed to deliver 370W to the PoE ports plus 50 ish watts to the switch itself. That makes a 400-420W load, that at an efficiency of 85-90% (the psu looks to me to be an active PFC, LLC resonant converter) will push out some 40-60W heat on top of the 50W the switch already dissipates at idle. We're talking above 100W in an 1U form factor with 2 fans, which will require some airflow.

My plan is to run the switch way lower in PoE power, currently I've got three TP-Link omada access points that draw around 5W each, and a couple security cameras / doorbells that do at best 3-4W. If I'm getting to 40W it'll be a lot. I've bought this switch mostly for the 8x10g sfp side and to consolidate 2 switches into a single one.

I like the idea of doing some diy stuff to push air into the side psu port. I've got about 4.5cm space from the switch to the side of the rack cabinet, and the intake vent is 12x3cm. I could easily design and 3d print an adapter to fit two or three small 40x40 fans for some additional airflow.
 

clcorbin

Member
Feb 15, 2014
74
10
8
I have a question regarding the ICX 7750-48F. I currently have two ICX 6610 running as a stack. Due my "need" for additional 40Gbe ports, I am going to break the stack and replace the 6610 in the rack with the 7750.

Today, I was working on getting the 7750 configured correctly and assigning VLANs to ports (mostly to match 6610 so it will be a "drop in" as much as possible). I noticed that on the 6610, when I setup a vlan trunk, it displayed Tag = Yes and Pvid = N/A. However, setting up the same trunk on the 7750 shows Tag = Yes and Pvid = 99 (in my case, my default VLAN).

Does this indicated that the ports on the 7750 (software version 08.0.95nT203) run in hybrid mode by default? That was my original guess, however when I tried to add that port to my management vlan as untagged, it said the port was already a member of that vlan (per the trunk).

Feels like I am doing something wrong here due to the newer software version in the 7750...

Regards,

Clint
 

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
If for some reason you find it still isn't sufficient, one hacky thing you could do is strap a fan externally next to the PSU inlet on the side. I know someone who has it in a closet that did this. It'll provide more airflow explicitly to the PSU (which it seems is actually the first thing to overheat post-mod).
And... Done!

I've designed and 3d printed a bracket to add 3x 40x40 fans to the side of an 1U switch. If anyone wants to print one, the stl files are here.

3x40mm_FanMount_1.jpg 3x40mm_FanMount_2.jpg

With the fans running at 5V off an USB port, the additional intake lowered the PSU temperature by 4°C and the SoC temp by about 2-3°C. The switch is inside my rack, with the front door closed, and two 120mm fans blowing out exhaust air up.

Before:
Slot 1 Current Temperature: 72.4 deg-C (Sensor 1), 43.5 deg-C (Sensor 2)
After:
Slot 1 Current Temperature: 69.7 deg-C (Sensor 1), 39.5 deg-C (Sensor 2)
 

tubs-ffm

Active Member
Sep 1, 2013
187
64
28
Does anybody know about compatibility issues on PoE devices?

I am using my ICX 7150-C12P powering two devices without issues. When I connect my Snom M900 DECT directly to the switch is does not run. It gets power, it boots, but either the ethernet port on ICX is completely down or no data goes through. When I connect the same device with a separate PoE adapter to the same port at the ICX all is fine. The M900 is 802.af class 2 compatible.

Any possibilities to do do some manual setting on the ICX for the port?
 

andrea87

Active Member
Oct 15, 2022
86
100
33
37
North-east Italy
Any possibilities to do do some manual setting on the ICX for the port?
with the device attached, can you do a show interface ethe 1/1/x on the port and paste here the results? These are the ones I get on my 7250 with a PoE AP:

SSH@ICX7250-24P>show interface ethe 1/1/21
GigabitEthernet1/1/21 is up, line protocol is up
Port up for 1 day(s) 4 hour(s) 54 minute(s) 29 second(s)
Hardware is GigabitEthernet, address is 609c.9f06.0880 (bia 609c.9f06.0894)
Configured speed auto, actual 1Gbit, configured duplex fdx, actual fdx
Configured mdi mode AUTO, actual MDI
EEE Feature Disabled
Tagged member of 3 L2 VLANs, untagged in VLAN 1, port state is FORWARDING
BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
Link Error Dampening is Disabled
STP configured to ON, priority is level0, mac-learning is enabled
MACsec is Disabled
Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is config enabled, oper enabled, negotiation disabled
Mirror disabled, Monitor disabled
Mac-notification is disabled
VLAN-Mapping is disabled
Not member of any active trunks
Not member of any configured trunks
Port name is AP Esterno
IPG MII 96 bits-time, IPG GMII 96 bits-time
MTU 10200 bytes, encapsulation ethernet
MMU Mode is Store-and-forward
300 second input rate: 19608 bits/sec, 22 packets/sec, 0.00% utilization
300 second output rate: 552456 bits/sec, 51 packets/sec, 0.05% utilization
1736003 packets input, 274338698 bytes, 0 no buffer
Received 1538 broadcasts, 13767 multicasts, 1720698 unicasts
0 input errors, 0 CRC, 0 frame, 0 ignored
0 runts, 0 giants
4324033 packets output, 5622405691 bytes, 0 underruns
Transmitted 152292 broadcasts, 73249 multicasts, 4098492 unicasts
0 output errors, 0 collisions
Relay Agent Information option: Disabled
Protected: No
MAC Port Security: Disabled

From what I can find on the item's page, it's a 10/100 PoE device, you could try forcing the port to work at 100mbit full duplex mode:

(in config mode)
interface ethe 1/1/x
speed-duplex 100-full
exit

the port will cycle, and it will be forced to the desired negotiation speed.

to undo, set speed-duplex to auto on the port.
 

itronin

Well-Known Member
Nov 24, 2018
1,285
852
113
Denver, Colorado
Does anybody know about compatibility issues on PoE devices?

I am using my ICX 7150-C12P powering two devices without issues. When I connect my Snom M900 DECT directly to the switch is does not run. It gets power, it boots, but either the ethernet port on ICX is completely down or no data goes through. When I connect the same device with a separate PoE adapter to the same port at the ICX all is fine. The M900 is 802.af class 2 compatible.

Any possibilities to do do some manual setting on the ICX for the port?
Are you running LLDP on the switch?
 

tubs-ffm

Active Member
Sep 1, 2013
187
64
28
Are you running LLDP on the switch?
It is not enabled by intention. I already read that LLDP may cause issues on M900.
Here is my config.

Code:
SSH@switch01#show run
Current configuration:
!
ver 09.0.10j_cd3T213
!
stack unit 1
  module 1 icx7150-c12-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-2-sfp-plus-port-20g-module
!
!
!
global-stp
!
!
default-vlan-id 2
!
vlan 2 name DEFAULT-VLAN by port
 spanning-tree
!
vlan 10 name DMZ by port
 tagged ethe 1/1/3 ethe 1/2/1
 untagged ethe 1/3/2
 spanning-tree
!
vlan 20 name IoT by port
 tagged ethe 1/1/3 ethe 1/1/5 ethe 1/2/1
 spanning-tree
!
vlan 30 name Guest by port
 tagged ethe 1/1/3 ethe 1/1/5 ethe 1/2/1
 spanning-tree
!
!
!
!
!
!
ip route 0.0.0.0/0 192.168.2.1
optical-monitor
optical-monitor non-ruckus-optic-enable
ipv6 route ::/0 fd00:0:0:2::1
!
!
!
clock summer-time
clock timezone gmt GMT+01
boot system flash primary
jitc enable
hostname switch01
ip dns domain-list domain.lan
ip dns server-address 192.168.2.1 192.168.2.15
ip tftp blocksize 8192
ipv6 dns server-address fd00:0:0:2::1 fd00:0:0:2::15
ipv6 unicast-routing
!
!
ntp
 disable authenticate md5
 master stratum 5
 server 0.de.pool.ntp.org
 server 1.de.pool.ntp.org
 server 2.de.pool.ntp.org
 server 3.de.pool.ntp.org
 peer 192.168.2.1
 peer 192.168.2.3
 peer 192.168.2.10
!
!
!
!
!
!
!
!
!
interface management 1
 ip address 192.168.71.50 255.255.255.0
!
interface ethernet 1/1/1
 port-name OPNsense-LAN
 dhcp6 snooping trust
 dhcp snooping trust
 arp inspection trust
!
interface ethernet 1/1/2
 disable
!
interface ethernet 1/1/3
 port-name opnsense-trunk
 dhcp6 snooping trust
 dhcp snooping trust
 arp inspection trust
!
interface ethernet 1/1/4
 disable
!
interface ethernet 1/1/5
 port-name ap
!
interface ethernet 1/1/6
 disable
!
interface ethernet 1/1/7
 port-name wohnzimmer
!
interface ethernet 1/1/8
 disable
!
interface ethernet 1/1/9
 port-name ip-phone
 no inline power
!
interface ethernet 1/1/10
 port-name NO PoE
 no inline power
!
interface ethernet 1/1/11
 port-name Homeassistant
!
interface ethernet 1/1/12
 disable
!
interface ethernet 1/2/1
 port-name office
 arp inspection trust
!
interface ethernet 1/2/2
 disable
!
interface ve 2
 ip address 192.168.2.2 255.255.255.0
 ipv6 address fd00:0:0:2::2/64
!
!

!
!

ipv6 dhcp6 snooping vlan 2 10 20 30

!
ip dhcp snooping vlan 2 10 20 30
!
ip dhcp snooping verify mac-address
!


!
!
!
!
username super password .....
!
aaa authentication login default local
!
aaa authentication web-server default local
!
aaa authentication snmp-server default local
!
ip dhcp-client disable
!
logging host 192.168.2.4 udp-port 6514
!


!
web-management session-timeout 3600
!
ip ssh encryption aes128-ctr aes192-ctr aes256-ctr


ip ssh key-exchange-method diffie-hellman-group16-sha512 diffie-hellman-group18-sha512 ecdh-sha2-nistp256 ecdh-sha2-nistp384 ecdh-sha2-nistp521

!


!
no telnet server
!
snmp-server community 2 $xxxxx== ro
snmp-server community 2 $xxxx ro
snmp-server location office
snmp-server group admin v3 auth notify all read all write all
snmp-server user homeassistant admin v3 encrypted auth sha xxxx priv encrypted aes xxxx
!
manager disable
manager port-list 987
!
cli timeout 0
!


!


!

end


with the device attached, can you do a show interface ethe 1/1/x on the port and paste here the results? These are the ones I get on my 7250 with a PoE AP:
It is getting confusing. It looks my issue is a different one.

To generate the status for the interface I switched the ports with having the the M900 connected to the PoE adapter. The first the port was up but no I could not get a connection. Switch ports a second time the port changed to status down.

What I noticed are connection errors in the port status and state blocking:

Code:
Untagged member of L2 VLAN 2, port state is BLOCKING
[...]
42084 input errors, 33974 CRC, 0 frame, 0 ignored
The issue seems not to be related to PoE as assumed before. Something faulty on the ICX or the M900 I believe.

Status with PoE adapter after 1st port change:

Code:
SSH@switch01#show interface ethe 1/1/9
GigabitEthernet1/1/9 is up, line protocol is up
  Port up for 4 minute(s) 20 second(s)
  Hardware is GigabitEthernet, address is d4c1.9e8a.68e0 (bia d4c1.9e8a.68e8)
  Configured speed auto, actual 100Mbit, configured duplex fdx, actual fdx
  Configured mdi mode AUTO, actual MDIX
  Untagged member of L2 VLAN 2, port state is FORWARDING
  BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
  Link Error Dampening is Disabled
  STP configured to ON, priority is level0, mac-learning is enabled
  MACsec is Disabled
  Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is config enabled, oper enabled, negotiation disabled
  Mirror disabled, Monitor disabled
  Mac-notification is disabled
  VLAN-Mapping is disabled
  Not member of any active trunks
  Not member of any configured trunks
  Port name is ip-phone
  IPG MII 96 bits-time, IPG GMII 96 bits-time
  MTU 1500 bytes, encapsulation ethernet
  MMU Mode is Store-and-forward
  300 second input rate: 221312 bits/sec, 0 packets/sec, 0.21% utilization
  300 second output rate: 9712 bits/sec, 5 packets/sec, 0.00% utilization
  0 packets input, 7356869 bytes, 0 no buffer
  Received 0 broadcasts, 0 multicasts, 0 unicasts
  27029 input errors, 21849 CRC, 0 frame, 0 ignored
  5079 runts, 101 giants
  1375 packets output, 320704 bytes, 0 underruns
  Transmitted 263 broadcasts, 1110 multicasts, 2 unicasts
  0 output errors, 0 collisions
  Relay Agent Information option: Disabled
  Protected: No
  MAC Port Security: Disabled
 Flexlink: Disabled

 This port is not being monitored for queue drops
Egress queues:
Queue counters    Queued packets        Dropped Packets
         0                 764                   0
         1                   0                   0
         2                   0                   0
         3                   0                   0
         4                 414                   0
         5                  59                   0
         6                   0                   0
         7                 138                   0


Status with PoE adapter after 2nd port change:

Code:
SSH@switch01#show interface ethe 1/1/9
GigabitEthernet1/1/9 is down, line protocol is down
  Port down for 1 minute(s) 33 second(s)
  Hardware is GigabitEthernet, address is d4c1.9e8a.68e0 (bia d4c1.9e8a.68e8)
  Configured speed auto, actual unknown, configured duplex fdx, actual unknown
  Configured mdi mode AUTO, actual unknown
  Untagged member of L2 VLAN 2, port state is BLOCKING
  BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
  Link Error Dampening is Disabled
  STP configured to ON, priority is level0, mac-learning is enabled
  MACsec is Disabled
  Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is config enabled, oper enabled, negotiation disabled
  Mirror disabled, Monitor disabled
  Mac-notification is disabled
  VLAN-Mapping is disabled
  Not member of any active trunks
  Not member of any configured trunks
  Port name is ip-phone
  IPG MII 96 bits-time, IPG GMII 96 bits-time
  MTU 1500 bytes, encapsulation ethernet
  MMU Mode is Store-and-forward
  300 second input rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
  300 second output rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
  0 packets input, 11371221 bytes, 0 no buffer
  Received 0 broadcasts, 0 multicasts, 0 unicasts
  42084 input errors, 33974 CRC, 0 frame, 0 ignored
  7971 runts, 139 giants
  2125 packets output, 496026 bytes, 0 underruns
  Transmitted 407 broadcasts, 1715 multicasts, 3 unicasts
  0 output errors, 0 collisions
  Relay Agent Information option: Disabled
  Protected: No
  MAC Port Security: Disabled
 Flexlink: Disabled

 This port is not being monitored for queue drops
Egress queues:
Queue counters    Queued packets        Dropped Packets
         0                1200                   0
         1                   0                   0
         2                   0                   0
         3                   0                   0
         4                 634                   0
         5                  76                   0
         6                   0                   0
         7                 215                   0
 

tubs-ffm

Active Member
Sep 1, 2013
187
64
28
It is not enabled by intention. I already read that LLDP may cause issues on M900.
Here is my config.
Update.

It looks like I am facing 3 different issues.

1) The ICX has no LLDP but my Ruckus Unleashed. My error is reproducable and the behaviour is as desctribed here. Not related to the ICX 7150
M900 and LLDP protocol - Snom Service Hub - Snom Confluence

I once tested with no lldp enable ports ethe 1/1/9, but the link did not came up.
Maybe this is because of (2)?

2) Still the ICX after reboot sometimes doe not get the port up and I need a second boot. When I connect it to an unmanged switch this indicates only a 10 MBit/s link. So far I tested on ICX to set to 100MBit full duplex because the M900 can do acc. technical spec. Maybe broken?

3) The CRC errors seems to come from a shitty cable or it is related to (2).
 

RoachedCoach

Member
Feb 4, 2020
42
48
18
And... Done!

I've designed and 3d printed a bracket to add 3x 40x40 fans to the side of an 1U switch. If anyone wants to print one, the stl files are here.

View attachment 38966 View attachment 38967

With the fans running at 5V off an USB port, the additional intake lowered the PSU temperature by 4°C and the SoC temp by about 2-3°C. The switch is inside my rack, with the front door closed, and two 120mm fans blowing out exhaust air up.

Before:
Slot 1 Current Temperature: 72.4 deg-C (Sensor 1), 43.5 deg-C (Sensor 2)
After:
Slot 1 Current Temperature: 69.7 deg-C (Sensor 1), 39.5 deg-C (Sensor 2)
That's quite snazzy and I love it. Good job!
 

tubs-ffm

Active Member
Sep 1, 2013
187
64
28
It looks like I am facing 3 different issues.

1) The ICX has no LLDP but my Ruckus Unleashed. My error is reproducable and the behaviour is as desctribed here. Not related to the ICX 7150
M900 and LLDP protocol - Snom Service Hub - Snom Confluence

I once tested with no lldp enable ports ethe 1/1/9, but the link did not came up.
Maybe this is because of (2)?

2) Still the ICX after reboot sometimes doe not get the port up and I need a second boot. When I connect it to an unmanged switch this indicates only a 10 MBit/s link. So far I tested on ICX to set to 100MBit full duplex because the M900 can do acc. technical spec. Maybe broken?

3) The CRC errors seems to come from a shitty cable or it is related to (2).
My issue is "solved", or better to say I found a workaround.

The, in my eyes faulty behaviour of the Snom M900 in combination with LLDP packets, I solved by blocking them on the port of the ICX
Code:
no lldp enable ports ethe 1/1/9
The "incompatibility" between both devices not getting a proper link I solved by setting the port to a fixed copper link of 10 MBit.
Acc. spec, the NIC of the M900 is 10/100 MBit. But I only can get 10 Mbit running.
Code:
link-config gig copper autoneg-control 10m-full ethe 1/1/9
 
  • Like
Reactions: itronin