Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

tillburn

Member
Aug 23, 2020
31
26
18
Yes, you will need to add (as untagged or tagged) all VLANs that you want to traverse any port or LAG in the switch; the ICX devices don't have a pure 'trunk' mode where a port/LAG is automatically a member of all VLANs on the device.

The LAG is part of VLAN 1 untagged by default, so if you are using that for management connections then you're all set. You'll just need to add all of the tagged VLANs as well (and set 'dual-mode' if it's an ICX 66xx I think).
When I enter conf t on the 7250 and enter "interface ?" I get a list of ethernet, group-ve, lag, loopback, management, tunnel, ve.
When I enter conf t on the 6610 the interface ? doesn't show "lag".

Would assuming that adding dual-mode to the interface eth 1/3/1 after tagging the vlans is the appropriate way to enter dual-mode for the lag 1 that I created? I added dual mode on the 6610 to eth 1/3/1 after adding 1/3/1 to vlan 10 and now lag 1 is working as expected. Thanks for the heads up on dual mode, I guess things a little more complicated by using two switches not of the same model series, but also on difference firmware revisions. At least I am learning, thanks again!!

Now I am off to the greater networking thread to read up on pfsense and inter-vlan routing so I can make the best decision for my hardware and needs.
 
Last edited:

Krextyl

New Member
Jan 6, 2023
2
0
1
I am new to the scene and just recently picked up an ICX 6610 - 48P largely in part due to this write-up. I have next to no experience but figured I'd use this as a learning opportunity/experiment to strengthen my knowledge of networking not to mention the performance benefits. I'm learning as I go but apparently I need baby steps :).

I'm following the guide as well as supplementing it with additional sources for example learning what a management port is (see baby steps). At any rate, I've reached a point where I'm stumped, unfortunately, it's not far into the guide (timeout on copy of the flash files from the TFTP Server). I was wondering if someone might be able to help get beyond my hurdle.

I've got the TFTP (on windows client) from the main zip file provided and running as it was pre-configured. I've ensured the current directory is set to the unzipped TFTP-Content folder, and I've set the server interface to my connected PC's IP 192.168.50.25. If I show dir and browse I confirmed I can see the grz10100.bin file.

For the terminal window, I'm using Putty. Using serial connection with it set to COM3, 9600 Baud, 8 data bits, 1 stop bits, no parity and Xon/Xoff flow control (I've also tried none for flow control with same result).

COM3 is my USB com port that the rj45/usb cable is connected on. I only have one other COM port on this machine and that is COM1, I tried it for giggles but no response as expected.

In putty I am able to hit b to enter boot and set an ip per the guide, I used 192.168.50.199/24 in my case. When I attempt the next step "copy tftp flash 192.168.50.25 ICX6610-FCX/grz10100.bin boot" it seems to be working for a few moments but then it times out.

Given I'm getting responses and such through Putty I see no reason to think it's anything on that end but rather some issue with the TFTP config. I have closed it and relaunched it trying to go into the subfolder and omit that in the copy command and same issue. Not sure about things I started looking at other sources for possible issues and found a video somewhat related stating I may need to check the switch's space to see if it has room to copy the flashover, otherwise I may need to delete files to make space - that made sense but also nervous being a novice not knowing what could be safely deleted etc so I didn't do anything. I did look at the TFTP settings and have tried it with tftp bound to 192.168.50.25 to see if that would help but didn't make a difference.

I am stumped please help,
 

tillburn

Member
Aug 23, 2020
31
26
18
I am new to the scene and just recently picked up an ICX 6610 - 48P largely in part due to this write-up. I have next to no experience but figured I'd use this as a learning opportunity/experiment to strengthen my knowledge of networking not to mention the performance benefits. I'm learning as I go but apparently I need baby steps :).

I'm following the guide as well as supplementing it with additional sources for example learning what a management port is (see baby steps). At any rate, I've reached a point where I'm stumped, unfortunately, it's not far into the guide (timeout on copy of the flash files from the TFTP Server). I was wondering if someone might be able to help get beyond my hurdle.

I've got the TFTP (on windows client) from the main zip file provided and running as it was pre-configured. I've ensured the current directory is set to the unzipped TFTP-Content folder, and I've set the server interface to my connected PC's IP 192.168.50.25. If I show dir and browse I confirmed I can see the grz10100.bin file.

For the terminal window, I'm using Putty. Using serial connection with it set to COM3, 9600 Baud, 8 data bits, 1 stop bits, no parity and Xon/Xoff flow control (I've also tried none for flow control with same result).

COM3 is my USB com port that the rj45/usb cable is connected on. I only have one other COM port on this machine and that is COM1, I tried it for giggles but no response as expected.

In putty I am able to hit b to enter boot and set an ip per the guide, I used 192.168.50.199/24 in my case. When I attempt the next step "copy tftp flash 192.168.50.25 ICX6610-FCX/grz10100.bin boot" it seems to be working for a few moments but then it times out.

Given I'm getting responses and such through Putty I see no reason to think it's anything on that end but rather some issue with the TFTP config. I have closed it and relaunched it trying to go into the subfolder and omit that in the copy command and same issue. Not sure about things I started looking at other sources for possible issues and found a video somewhat related stating I may need to check the switch's space to see if it has room to copy the flashover, otherwise I may need to delete files to make space - that made sense but also nervous being a novice not knowing what could be safely deleted etc so I didn't do anything. I did look at the TFTP settings and have tried it with tftp bound to 192.168.50.25 to see if that would help but didn't make a difference.

I am stumped please help,
I am no expert lol, so take this with a grain of mega salt...

A sanity check would be to make sure if using windows that the firewall isn't blocking your tftp server application.

1674426968239.png

command would be: copy tftp flash IPHERE grz10100.bin bootrom (boot works too)

Can you sh ver , sh firmware ver , sh flash
You can use this video to help:
 

kpfleming

Active Member
Dec 28, 2021
401
208
43
Pelham NY USA
Would assuming that adding dual-mode to the interface eth 1/3/1 after tagging the vlans is the appropriate way to enter dual-mode for the lag 1 that I created?
I don't believe that is the correct thing to do; once you have created a LAG, you need to apply VLAN configuration and similar things to the LAG, not to the interfaces inside it.

At this point it would be really helpful if you could post your config files (passwords removed, if there are any), because otherwise we're just seeing snippets as you ask questions.
 

Krextyl

New Member
Jan 6, 2023
2
0
1
I am no expert lol, so take this with a grain of mega salt...

Thank you for the information, great point about possible windows firewall. I'll check these suggestions out when I'm back at the switch and able to fire it back up, etc.
 

tillburn

Member
Aug 23, 2020
31
26
18
I don't believe that is the correct thing to do; once you have created a LAG, you need to apply VLAN configuration and similar things to the LAG, not to the interfaces inside it.

At this point it would be really helpful if you could post your config files (passwords removed, if there are any), because otherwise we're just seeing snippets as you ask questions.
I attached the configs for both if there is a more convenient way to post the configs I am happy to do that too, let me know.

Let me know how I can improve my config please and thank you for helping!
 

Attachments

  • Like
Reactions: kpfleming

LodeRunner

Active Member
Apr 27, 2019
546
228
43
Attachment is fine, you can also paste the full text in a code block wrapped in tags. [ spoiler ][ code ] config here [ /code ] [ /spoiler ] (but without the spaces between the words and the brackets).
 

itronin

Well-Known Member
Nov 24, 2018
1,256
817
113
Denver, Colorado
@LodeRunner beat me to the reply. Teach me to not refresh before posting. :p

I attached the configs for both if there is a more convenient way to post the configs I am happy to do that too, let me know.

Let me know how I can improve my config please and thank you for helping!
A quicky for your configs.

a code block for each config and then wrap a spoiler block around it all.
the spoiler keeps the page size down for those folks uninterested. the code block keeps the formatting reasonable.

me, I'd download your attachments and open each one in a window so I can flip back and forth - so attaching is also good.
Just as easy to cut-n-paste as to download the files though.

config 6610
Code:
ver 08.0.30uT7f3
!
stack unit 1
  module 1 icx6610-48p-poe-port-management-module
  module 2 icx6610-qsfp-10-port-160g-module
  module 3 icx6610-8-port-10g-dual-mode-module
stack disable
stack mac 748e.f8cf.f71a
!
global-stp
!
!
lag uplink1 dynamic id 1
ports ethernet 1/3/1
primary-port 1/3/1
deploy
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree priority 26000
!
vlan 10 name Management by port
tagged ethe 1/3/1
!
vlan 20 name Servers_Data by port
tagged ethe 1/3/1
!
vlan 30 name IOT by port
tagged ethe 1/3/1
!
vlan 40 name Sec_Cam by port
tagged ethe 1/3/1
!
vlan 50 name Sparklight by port
tagged ethe 1/3/1
untagged ethe 1/1/1
!
vlan 51 name StarLink by port
!
vlan 60 name Additive by port
tagged ethe 1/3/1
!
vlan 777 name Native by port
tagged ethe 1/3/1
!
optical-monitor
aaa authentication web-server default local
aaa authentication login default local
enable telnet authentication
enable super-user-password .....
hostname SW01
ip dhcp-client disable
ip dns server-address 10.10.100.1
ip route 0.0.0.0/0 10.10.100.1
!
username  password .....
!
!
clock summer-time
clock timezone gmt GMT-08
!
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
!
!
web-management https
hitless-failover enable

interface ethernet 1/3/1
dual-mode
speed-duplex 10G-full
!
interface ethernet 1/3/2
speed-duplex 10G-full
!
interface ethernet 1/3/3
speed-duplex 10G-full
!
interface ethernet 1/3/4
speed-duplex 10G-full
!
interface ethernet 1/3/5
speed-duplex 10G-full
!
interface ethernet 1/3/6
speed-duplex 10G-full
!
interface ethernet 1/3/7
speed-duplex 10G-full
!
interface ethernet 1/3/8
speed-duplex 10G-full
!
interface ve 1
ip address 10.100.10.3 255.255.255.0
!

ip ssh  idle-time 240
config 7250
Code:
ver 08.0.95hT213
!
stack unit 1
  module 1 icx7250-48p-poe-port-management-module
  module 2 icx7250-sfp-plus-8port-80g-module
stack mac 609c.9f07.21a8
!
!
!
lag uplink1 dynamic id 1
ports ethe 1/2/1
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
vlan 10 name Management by port
tagged lag 1
!
vlan 20 name Servers_Data by port
tagged lag 1
!
vlan 30 name IOT by port
tagged lag 1
!
vlan 40 name Sec_Cam by port
tagged lag 1
!
vlan 50 name Sparklight by port
tagged lag 1
untagged ethe 1/1/1
!
vlan 51 name Starlink by port
!
vlan 60 name Additive by port
tagged lag 1
!
vlan 777 name Native by port
tagged lag 1
!
optical-monitor
optical-monitor non-ruckus-optic-enable
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
enable telnet authentication
hostname SW00
ip dhcp-client disable
ip dns server-address 10.10.100.1
ip route 0.0.0.0/0 10.10.100.1
!
username  password .....
!
snmp-server community ..... ro
!
clock summer-time
clock timezone gmt GMT-08
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
!
hitless-failover enable
!
manager disable
!
manager port-list 987
!
interface ve 1
ip address 10.100.10.2 255.255.255.0
!
no lldp run
!
ip ssh  idle-time 240
 
  • Like
Reactions: tillburn

kpfleming

Active Member
Dec 28, 2021
401
208
43
Pelham NY USA
I attached the configs for both if there is a more convenient way to post the configs I am happy to do that too, let me know.
For what it's worth the 7250 config looks correct based on what you have described as your desired configuration. I can't comment on the 6610 config as I've never used 08.0.30 or anything older and the configuration structure is quite different.
 

tillburn

Member
Aug 23, 2020
31
26
18
For what it's worth the 7250 config looks correct based on what you have described as your desired configuration. I can't comment on the 6610 config as I've never used 08.0.30 or anything older and the configuration structure is quite different.
I did try and set up the 6610 like I did the 7250, but lag 1 was not an option on the 6610. Maybe someone else has some input and knowledge they want to drop ;)
 

kpfleming

Active Member
Dec 28, 2021
401
208
43
Pelham NY USA
According to the docs for 08.0.30 you've done it correctly; the lowest-numbered port in the LAG (also called a 'trunk group') is the 'lead port' and any VLAN configuration applied to that port applies to all ports in the LAG.
 
  • Like
Reactions: tillburn

kpfleming

Active Member
Dec 28, 2021
401
208
43
Pelham NY USA
According to the docs for 08.0.30 you've done it correctly; the lowest-numbered port in the LAG (also called a 'trunk group') is the 'lead port' and any VLAN configuration applied to that port applies to all ports in the LAG.
So based on the configs you've posted, you should have a working configuration. All of the VLANs extend across the switches, and you've got an untagged port on VLAN 50 on both switches, so devices on those ports should be able to talk to each other.

What problems are you experiencing now?
 

tillburn

Member
Aug 23, 2020
31
26
18
So based on the configs you've posted, you should have a working configuration. All of the VLANs extend across the switches, and you've got an untagged port on VLAN 50 on both switches, so devices on those ports should be able to talk to each other.

What problems are you experiencing now?
None at all thank you for your help!

I do need to plan out the rest of the network conversion phase, mostly around taking the network more vertical with the vlans, using the proxmox to host the vm's/services and using pfsense or something else to handle all the intervlan routing. I think I can piece those things together and make an adaptive plan.

But if you had any advice for network layout given the unique situation I am all ears! Again I appreciate the help I have received!
 

itronin

Well-Known Member
Nov 24, 2018
1,256
817
113
Denver, Colorado
  • Like
Reactions: tillburn

selta

New Member
Jan 23, 2023
6
0
1
Having a good deal of trouble with the 40GbE ports on an ICX-6610, hoping for some help/sanity checks here. Server is a Dell R640 (can post full specs if needed).

First, sh flash and lic:
SSH@RackSwitch(config-if-e40000-1/2/6)#sh flash
Stack unit 1:
Compressed Pri Code size = 10545591, Version:08.0.30uT7f3 (ICX6610-FCX/FCXR08030u.bin)
Compressed Sec Code size = 7762230, Version:08.0.30nT7f1 (FCXS08030n.bin)
Compressed Boot-Monitor Image size = 370695, Version:10.1.00T7f5
Code Flash Free Space = 46399488
SSH@RackSwitch(config-if-e40000-1/2/6)#sh lic
Index Lic Mode Lic Name Lid/Serial No Lic Type Status Lic Period Lic Capacity
Stack unit 1:
1 Node Lock ICX6610-PREM-LIC-SW redacted Normal Invalid Unlimited 1
2 Node Lock ICX6610-10G-LIC-POD H4CKTH3PLN8 Normal Active Unlimited 8
3 Node Lock ICX-MACSEC-LIC H4CKTH3PLN8 Normal Active Unlimited 1
4 Node Lock ICX6610-ADV-LIC-SW H4CKTH3PLN8 Normal Active Unlimited 1
SSH@RackSwitch(config-if-e40000-1/2/6)#sh run
Current configuration:
!
ver 08.0.30uT7f3
!
stack unit 1
module 1 icx6610-48p-poe-port-management-module
module 2 icx6610-qsfp-10-port-160g-module
module 3 icx6610-8-port-10g-dual-mode-module
no legacy-inline-power
stack disable
!
!
Next, here's sh int output on the ICX:
SSH@RackSwitch(config-if-e40000-1/2/6)#sh int e 1/2/6
40GigabitEthernet1/2/6 is up, line protocol is up
Port up for 4 minute(s) 30 second(s)
Hardware is 40GigabitEthernet, address is 748e.f8dd.c154 (bia 748e.f8dd.c18a)
Interface type is 40Gig Fiber
Configured speed 40Gbit, actual 40Gbit, configured duplex fdx, actual fdx
Configured mdi mode AUTO, actual none
Member of L2 VLAN ID 2, port is untagged, port state is FORWARDING
BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
Link Error Dampening is Disabled
STP configured to ON, priority is level0, mac-learning is enabled
Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is enabled
Mirror disabled, Monitor disabled
Mac-notification is disabled
Not member of any active trunks
Not member of any configured trunks
Port name is Rear 40G
MTU 1500 bytes, encapsulation ethernet
300 second input rate: 80 bits/sec, 0 packets/sec, 0.00% utilization
300 second output rate: 8536 bits/sec, 11 packets/sec, 0.00% utilization
10746 packets input, 11471566 bytes, 0 no buffer
Received 159 broadcasts, 425 multicasts, 10162 unicasts
0 input errors, 0 CRC, 0 frame, 0 ignored
0 runts, 0 giants
461499 packets output, 35119251 bytes, 0 underruns
Transmitted 16789 broadcasts, 52196 multicasts, 392514 unicasts
0 output errors, 0 collisions
And finally, from the server (R640 w/ Intel XL710-Q2, Ubuntu 22.04.1):
selta@server2:~$ uname -r
5.15.0-58-generic

selta@server2:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04
Codename: jammy

3b:00.1 Ethernet controller: Intel Corporation Ethernet Controller XL710 for 40GbE QSFP+ (rev 02)
Subsystem: Intel Corporation Ethernet Converged Network Adapter XL710-Q2
Kernel driver in use: i40e
Kernel modules: i40e

selta@server2:~$ ifconfig enp59s0f1
enp59s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.3 netmask 255.255.252.0 broadcast 192.168.3.255
inet6 fe80::3efd:feff:fed0:2841 prefixlen 64 scopeid 0x20<link>
ether 3c:fd:fe:d0:28:41 txqueuelen 1000 (Ethernet)
RX packets 396762 bytes 26947129 (26.9 MB)
RX errors 25681 dropped 1689 overruns 0 frame 25680
TX packets 9977 bytes 11336141 (11.3 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

selta@server2:~$ ping -I enp59s0f1 4.2.2.1
PING 4.2.2.1 (4.2.2.1) from 192.168.1.3 enp59s0f1: 56(84) bytes of data.
64 bytes from 4.2.2.1: icmp_seq=1 ttl=57 time=29.3 ms
64 bytes from 4.2.2.1: icmp_seq=2 ttl=57 time=36.9 ms
64 bytes from 4.2.2.1: icmp_seq=3 ttl=57 time=29.8 ms

selta@server2:~$ sudo ethtool enp59s0f1
Settings for enp59s0f1:
Supported ports: [ FIBRE ]
Supported link modes: 40000baseCR4/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 40000baseCR4/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 40000Mb/s
Duplex: Full
Auto-negotiation: off
Port: Direct Attach Copper
PHYAD: 0
Transceiver: internal
Supports Wake-on: d
Wake-on: d
Current message level: 0x0000000f (15)
drv probe link timer
Link detected: yes

So my issue is that... this thing is just barely operational. As you can see, I can ping out from it even to a WAN address, so basic connectivity is there. However,ssh and any other type of connectivity beyond a basic ping just do not work (as in, no connection). ssh connections simply time out, nslookup fails due to timeout, apt update works but shows a throughput of a whopping 2KB/s.

To me, everything looks OK in dmesg:
[ 9.743896] i40e 0000:3b:00.1 eth0: NIC Link is Up, 40 Gbps Full Duplex, Flow Control: RX/TX
[ 10.074942] i40e 0000:3b:00.1: PCI-Express: Speed 8.0GT/s Width x8
[ 10.086993] i40e 0000:3b:00.1: Features: PF-id[1] VFs: 64 VSIs: 66 QP: 56 RSS FD_ATR FD_SB NTUPLE CloudF DCB VxLAN Geneve NVGRE PTP VEPA
[ 10.090389] i40e 0000:3b:00.0 enp59s0f0: renamed from eth1
[ 10.139769] i40e 0000:3b:00.1 enp59s0f1: renamed from eth0
[ 2132.001293] i40e 0000:3b:00.1 enp59s0f1: NIC Link is Down
[ 2132.815259] i40e 0000:3b:00.1 enp59s0f1: NIC Link is Up, 40 Gbps Full Duplex, Flow Control: RX/TX

And here's an iperf3 test to another server on the same subnet and VLAN, connected to the same switch as another example of the issue:
└─(21:24:10)──> iperf3 -s
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.1.3, port 56676
[ 5] local 192.168.1.0 port 5201 connected to 192.168.1.3 port 56692
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 7.48 MBytes 62.7 Mbits/sec
[ 5] 1.00-2.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 2.00-3.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 3.00-4.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 4.00-5.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 5.00-6.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 6.00-7.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 7.00-8.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 8.00-9.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 9.00-10.00 sec 0.00 Bytes 0.00 bits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -

I tried all of the same tests on 1/2/1, the other "stacking" 40GbE port with identical results. This is with a brand new QSFP cable (Arista brand, if that matters).
I tried with the i40e and the ixl drivers.

Kind of at a loss as to what else to check. I could buy another brand new QSFP if that's the suspect, but, I'd expect different issues if it were (CRC errors at least). Hopefully someone here can help - let me know if I missed providing any needed information.
 
Last edited:

selta

New Member
Jan 23, 2023
6
0
1
Interesting. I see at least 2-3 people here have the XL710 and the same issue I am having. I'm not going to sink more money into 40GbE here though -- my R640 came with the XL710, and was the only reason I was going to try to use it. I'll just use 10GbE and call it good. :)
 

tillburn

Member
Aug 23, 2020
31
26
18
So based on the configs you've posted, you should have a working configuration. All of the VLANs extend across the switches, and you've got an untagged port on VLAN 50 on both switches, so devices on those ports should be able to talk to each other.

What problems are you experiencing now?
I am reading up on spanning tree and rapid spanning tree, is there any primer you recommend? I feel like I am having some congestion on the network, specifically on the vlan carrying the cable modem as after about 6 hours the download speeds seems to be very slow, but if I reset both routers and the wireless AP the speeds for download are then just fine.

Physically it's laid out like this:

7250 port 1/1/1 vlan 50 ----->cable modem
7250 port 1/1/2 ------> unmanaged switch -----> 3x PC
7250 port 1/1/48 POE ----->wap (Vlans unimplemented yet).
7250 port 1/2/7 ----->10g Computer
7250 port 1/2/1 ----->10g LAG 1 all vlans -----> 6610

6610 port 1/1/1 vlan 50 ----->Pfsense VM
6610 port 1/1/2 Hypervisor 00
6610 port 1/1/3 Hypervisor 01
6610 port 1/1/48 POE ----> wap (Vlans unimplemented yet).
6610 port 1/3/1 -----> 10g LAG 1 all vlans------> 7250
6610 port 1/3/7 -----> 10g VM NAS
6610 port 1/3/8 -----> 10g VM Pfsense LAN

Any advice on spanning tree/rstp or if there potentially something else plaguing the network that I should be aware of please let me know.
 

Coach43

New Member
Jan 24, 2023
6
0
1
Not a network guy, but LOVE computers and what they can do!
Thank you Fohdeesha - I have TWO ICX6610's fully licensed and trunked via a 40Gb fiber optic link!
Instructions worked like a charm, but did not instill all layer 2 and layer 3 knowledge in me (I've been reading a lot of this 408 page forum etc, but still...)

The remote unit is a 6610P and I am now setting up security cameras. I'd like to isolate them onto their own vlan so they can't phone home to china or get accessed by the internet, but so they can still connect to my other internal systems. My firewall and DHCP are hosted upstream from the routers and that all works fine. I can easily add this new network there, I just need to make sure my 6610's know what's going on.

I think it's a few lines for those of you that know what you are doing.

My default network 192.168.1.0 and I'd like the new one to be 192.168.10.0.
I'm running router code.

Thanks in advance!


P.S. I'm interested in a 'Router Programming in a Nutshell' reference. Open to recommendations.