Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

carcass

New Member
Aug 14, 2017
13
2
3
38
I've just received 7150 from ebay, and looks like it won't go past bootloader:

Code:
Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
Any idea what is wrong and if anything can be done here?

Update. Sometimes I'm getting this during boot:

Code:
Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
initcall sequence 9f4944f0 failed at call f000eca8 (err=1)
### ERROR ### Please RESET the board ###

Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
ERROR : memory not allocated

Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
raise: Signal # 8 caught
 
Last edited:

fohdeesha

Kaini Industries
Nov 20, 2016
1,855
1,647
113
29
fohdeesha.com
I've just received 7150 from ebay, and looks like it won't go past bootloader:

Code:
Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
Any idea what is wrong and if anything can be done here?

Update. Sometimes I'm getting this during boot:

Code:
Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
initcall sequence 9f4944f0 failed at call f000eca8 (err=1)
### ERROR ### Please RESET the board ###

Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
ERROR : memory not allocated

Ruckus Wireless Bootloader: 10.1.11T225 (Dec 13 2017 - 03:13:30 -0800)

Booted from partition 1
DRAM:  Validate Shmoo parameters stored in flash ..... OK
raise: Signal # 8 caught

looks like bad RAM to me, does it ever at least drop you to a bootloader command line?
 

EngineerNate

Member
Jun 3, 2017
61
10
8
31
For the ICX7450-48P, I see that it supports 8 PoH (95W) ports and vague mentions of 802.3bt Type 3 and Type 4. Is this functionality that was introduced via a firmware update that we can update to or is it vaporware?
Scrolled through a few pages here, did we ever get a firm yay/nay on this?
 

ViciousXUSMC

Active Member
Nov 27, 2016
200
96
28
37
Stuck on something today.
Just bought a PoE splitter so I could run my Hue Hub closer to center of the house away from my server rack and AP interference.
I got this one: https://www.amazon.com/gp/product/B00MOIDXZ0/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

I hooked it up, turned on inline power and... nothing

I did some of the commands I had to do with my R710 like manually setting the Power-By-Class nothing.

Thinking the unit is defective I took it to the back of the house and hooked it up to my cheap Zyxel switch and it came on, working.

So I have been now trying every command I can find to get this working on the ICX 6450 without luck.

I tried decoupling the data link.
I ran the noinline power non-pd-detection enable and reloaded the switch
I tried all different power class settings.

I have the admin state of PoE enabled but nothing on the operating state.

When I had it on 1/1/5 I did get an error about PD Detection Fault, and that is what lead me to try to no inline power non-pd-detection command.
I moved it to 1/1/25 just in case it was a bad port, and I no longer get that error, but I still do not have power.

The R710 is still happy and running, so I know PoE works. Any ideas? What am I missing?
 

jd.developer

New Member
Jan 12, 2020
8
2
3
On my ICX6610, I noticed the license capacity is 8 for ICX6610-10G-LIC-POD. Does this mean I can only use a maximum of 8 10g ports between the front and breaking out the 2xQSFP+ ports on the back? Is there a separate license needed to use both the QSFP+ break outs and the 8 SFP ports on the front?
 

StarsAndBars

New Member
Jul 13, 2020
21
1
3
Just ordered my first 6610 to replace my home lab switch. I will probably be buying a second one soon after I get this first one configured. What is the preferred method (transceivers and cable parts) to link these? I also have a custom pfSense (Supermicro E300) box I just built that has SFP ports. If someone could link me to what they bought for interconnections, I would be VERY appreciative. Thanks in advance!
 

Spearfoot

Member
Apr 22, 2015
46
15
8
62
Just ordered my first 6610 to replace my home lab switch. I will probably be buying a second one soon after I get this first one configured. What is the preferred method (transceivers and cable parts) to link these? I also have a custom pfSense (Supermicro E300) box I just built that has SFP ports. If someone could link me to what they bought for interconnections, I would be VERY appreciative. Thanks in advance!
These switches aren't very fussy about DAC cables and transceivers. My 6610 has accepted every DAC cable I've tried on it (FiberStore, Molex, Cisco). My Finisar model FTLX8571D3BNL-E5 transceivers work too.

I'm using a pair of Arista DAC QSFP to 4 x SFP+ breakout cables to get 8 x 10G connections from the 40G breakout ports on the back of the switch:


My second 6610-48P arrives this morning. This switch has become an essential component of my home lab, and, like you, I wanted to have a spare.
 
  • Like
Reactions: fohdeesha

StarsAndBars

New Member
Jul 13, 2020
21
1
3
Thanks for the link, unfortunately it is out of stock. What does your connectivity between your firewall/router and your first 6610? What cables/modules? How do you plan to link the switches?
 

Spearfoot

Member
Apr 22, 2015
46
15
8
62
Thanks for the link, unfortunately it is out of stock. What does your connectivity between your firewall/router and your first 6610? What cables/modules? How do you plan to link the switches?
Yeah, I noticed they were out of stock after I posted my reply... you can search for similar breakout cables, though.

My 6610-48P is out in my shop. I use the two breakout cables for SFP+ connections to 3 servers there -- each has a dual ported 10G NIC, so that's 6 x SFP+ connections. The only front panel SFP+ port I'm using is for a fiber run from the shop to my office switch (a Ruckus ICX 7150-C12P) using the Finisar transceivers I mentioned above.

I hired a local company to pull fiber from my shop to my office, installing wall sockets on each end. I don't know the brand or model number of the fiber they used. The patch cables I'm using are standard LC OM3 models, purchased on Amazon:


I won't be using my second 6610; it's a cold spare to replace the shop switch if necessary.

I use a standard 'trunk' connection between all of my switches (office, shop, living room). My setup is pretty simple with only a few VLANs. I use pfSense for firewall & routing, running it as a VM on a small AIO server in my office. I pass a quad Gb Intel NIC through to this VM, with one port each for AT&T and Comcast; a trunk port to the 7150; and the fourth port connected to my work laptop (which has its own VLAN).
 

EngineerNate

Member
Jun 3, 2017
61
10
8
31
I decided to pick up an ICX7450-48P for the higher power PoE capability--I forsee more powerful access points being a bigger need for me than >4 or >8 10G ports. Power is listed at ~80W lower per Brocade vs the 6610, so hopefully their estimates are equally conservative on this switch. This felt like a good compromise between the 7250 and 6610 as far as capability and also has the higher power PoE capability. They do list 802.3BT "ready" in the datasheet, so I'm curious if I plug in an 802.3BT device if it'll work at full power. I know it can power the Ruckus APs that exceed PoE+ at full power (R730) and it does 90W PoH so I don't see why it wouldn't work for any PoE++ devices.

I picked up a 4x10G module for it and I have a bid in on 2x 40G modules. I'll test out a breakout cable in the 40G module and report back, and I'll also report back on power usage as I don't think I found that listed anywhere for the ICX7450.

Cheers,
Nathan
 

EngineerNate

Member
Jun 3, 2017
61
10
8
31
Found my answer regarding ICX7450 PoE++/802.3BT capability. At the time of publishing the article shown below, it's rated for 802.3BT (PoE++) Type 3 (60W):

 

StarsAndBars

New Member
Jul 13, 2020
21
1
3
Yeah, I noticed they were out of stock after I posted my reply... you can search for similar breakout cables, though.

My 6610-48P is out in my shop. I use the two breakout cables for SFP+ connections to 3 servers there -- each has a dual ported 10G NIC, so that's 6 x SFP+ connections. The only front panel SFP+ port I'm using is for a fiber run from the shop to my office switch (a Ruckus ICX 7150-C12P) using the Finisar transceivers I mentioned above.

I hired a local company to pull fiber from my shop to my office, installing wall sockets on each end. I don't know the brand or model number of the fiber they used. The patch cables I'm using are standard LC OM3 models, purchased on Amazon:


I won't be using my second 6610; it's a cold spare to replace the shop switch if necessary.

I use a standard 'trunk' connection between all of my switches (office, shop, living room). My setup is pretty simple with only a few VLANs. I use pfSense for firewall & routing, running it as a VM on a small AIO server in my office. I pass a quad Gb Intel NIC through to this VM, with one port each for AT&T and Comcast; a trunk port to the 7150; and the fourth port connected to my work laptop (which has its own VLAN).
Thank you for the follow up. If you were in my shoes, and had all of your gear in a single rack, would you still use one of the breakout cables such as the one you linked? I have a whitebox pfSense firewall that has two SFP ports, and then I have a second (almost identical) whitebox (both are Supermicro E300) that I run ESXI 7 on. If I were to get a second 6610 I could then interconnect both of the 6610s and the two whiteboxes all with a single breakout cable, correct?

Thanks, I am just looking for the most cost-effective (but also high-performing) method to link up this gear. I know there is no real benefit in even 10G for the pfSense box, considering my ISP isn't even gigabit yet, but I would think 10G (or faster) would be the way to go between my 2 6610s and the ESXI server.
 

StarsAndBars

New Member
Jul 13, 2020
21
1
3
Does anyone have a link to a reseller who offers the AC version of the PSUs for the 6610 so I can put redundant in and also maybe have a cold spare or two? Does the Rev B/C apply to the chassis of the 6610 itself, or does the revision apply to the individual PSUs? Thanks!
 

EngineerNate

Member
Jun 3, 2017
61
10
8
31
Does anyone have a link to a reseller who offers the AC version of the PSUs for the 6610 so I can put redundant in and also maybe have a cold spare or two? Does the Rev B/C apply to the chassis of the 6610 itself, or does the revision apply to the individual PSUs? Thanks!
You'll have to just get lucky on eBay. I've seen them anywhere from $30-$200+. Wildly inconsistent. Might be more cost effective to buy a whole second switch if you want more than one spare.
 

kapone

Well-Known Member
May 23, 2015
772
368
63
Thank you for the follow up. If you were in my shoes, and had all of your gear in a single rack, would you still use one of the breakout cables such as the one you linked? I have a whitebox pfSense firewall that has two SFP ports, and then I have a second (almost identical) whitebox (both are Supermicro E300) that I run ESXI 7 on. If I were to get a second 6610 I could then interconnect both of the 6610s and the two whiteboxes all with a single breakout cable, correct?

Thanks, I am just looking for the most cost-effective (but also high-performing) method to link up this gear. I know there is no real benefit in even 10G for the pfSense box, considering my ISP isn't even gigabit yet, but I would think 10G (or faster) would be the way to go between my 2 6610s and the ESXI server.
If all you have are these two "white boxes"...and your internet speeds aren't even gigabit...you're thinking of TWO 6610s??

Edit: To give you an idea...the attached picture shows all of the stuff running off of a single 6610 with two symmetric gigabit WAN connections. And it's not even utilized 60% yet. (Left pic is top half of rack, right pic is bottom half)

IMG_0298 copy.jpg