Avago LSI MegaRaid 9260-8i cannot import foreign config

Discussion in 'RAID Controllers and Host Bus Adapters' started by PeteD, Nov 11, 2019.

  1. PeteD

    PeteD New Member

    Joined:
    Nov 11, 2019
    Messages:
    2
    Likes Received:
    1
    Hello,

    After a HBA failure I've replaced it with the identical model I had.
    When booted up it presented me the screen to import a foreign config.
    Nothing unexpected so far, however the problem began when it failed to import that foreign config.
    Booting into Windows and using MSM, given me the similar error:
    "Foreign drives cannot be imported as they don't form a complete configuration."

    There were 3 HDDs and 2 virtual drives. 2xHDD (7200 NL-SAS) in RAID1 and a single drive (SATA 7200) in RAID0.
    My assumption is that data on all drives is still intact (except raid config?).

    My questions are:
    1. Can I clear the config WITHOUT losing data?
    2. Re-create the RAID1 and force online without initialization?

    or
    3. Create a virtual drive using a single drive and copy the data over before rebuilding RAID.

    I can move HDD no3. and attach it directly to the motherboard, however the most important data sits on 2xSAS disks and therefore that's not an option.

    4. Can I use a different HBA (HP P212) to 'import' a single disk just to make data visible?

    5. Contemplating whether Seagate st1000nm0023 is capable of operating in SATA mode in which case could be a matter of a SAS to SATA converter?

    6. Or have I got this completely wrong and data on disks cannot be read by standard MB SATA controller due to additional metadata that HBAs write on the disk?


    Any suggestions welcome, as I am trying to avoid restoring backups and rebuilding a complete virtualization server.
     
    #1
    Last edited: Nov 11, 2019
  2. pricklypunter

    pricklypunter Well-Known Member

    Joined:
    Nov 10, 2015
    Messages:
    1,524
    Likes Received:
    434
    I would be taking an image/ bit copy of each disk before doing anything else, if the data is critical :)
     
    #2
  3. j_h_o

    j_h_o Active Member

    Joined:
    Apr 21, 2015
    Messages:
    369
    Likes Received:
    74
    1. An HBA is different from a RAID controller; you mention HBA, but then you're talking about a 9260-8i which is a RAID controller. You previously had the exact same controller?
    2. If you clear config from the disks you will lose data.
    3. How did you realise the previous controller had failed? Perhaps it was spraying bad bits onto the disks as well...?
    You should flash the controller to the latest/same-as-previous firmware. Then it should import the foreign disks. There won't be data loss.
     
    #3
  4. Sleyk

    Sleyk Active Member

    Joined:
    Mar 25, 2016
    Messages:
    785
    Likes Received:
    212
    Spot on Jho, you said it correct. Just to piggyback off ya,

    Seems like our new member Pete is using LSI branded card, but they are in Megaraid mode. So its technically not pass-through of the drives. It seems that the failed controller corrupted the config. Therefore a new card wont "recognize" the config from the previous setup.

    Whatever OP does, he must find a way to transfer the data off the drives. The moment he breaks any sort of config or removes drives from where its supposed to be, he will lose data.

    OP, you mentioned being able to access the data? I would copy out all critical data, then just break everything and redo the config. IF you keep trying to fix the corrupted config without a clean backup, you might risk data.

    Trust me! I've been there. Back in the day, I kept trying to fix corrupted arrays. I would try to restore configs, and such forth. Never worked the same. Best to just salvage what you can, then redo the array.

    Plus your array isnt too big. You can certainly start over. Are we talking 10TB drives?

    Also, dont use a different raid card to import a drive. That raid card will write its own proprietary raid "dna" onto the disk, and then you might truly lose the data.
     
    #4
  5. PeteD

    PeteD New Member

    Joined:
    Nov 11, 2019
    Messages:
    2
    Likes Received:
    1
    Hi all.

    First of all, thanks for your replies.

    I managed to solve it and I thought I'd just post what worked for me which will save someone else some day :)

    Although I was lucky enough this time, I cannot stress how important is to have a fresh backup as I was inches from disaster!

    And yes it's not a HBA it's a RAID Card, my bad.


    Here is how I've solved it.
    1. Removed LSI card, and replaced it with an HP P212 that I had lying around.
    2. Booted into bare-metal Unix (FreeBSD in my case, but any Linux should do) system in preparation for cloning.
    Wonders happened here - HP card detected a RAID1 with all the data intact
    3. Bit-wise copy the original data from the RAID1 onto a 'salvage' HDD.
    4. Verify that clone is working and disconnect it.
    5. Put LSI card back in, gone into RAID config (Web-bios) clear the existing config (as LSI card still does not like it!) and reconfigure the RAID1 with the same parameters.
    6. IMPORTANT! If you want to retain the original data, finish RAID config, but DO NOT perform initialization.
    7. After reboot RAID came back up and booted. Happy days!

    I'd not take for granted that clearing config and re-creating would always get your data back, as few people pointed out already.
     
    #5
    Sleyk likes this.
Similar Threads: Avago MegaRaid
Forum Title Date
RAID Controllers and Host Bus Adapters Avago MegaRaid 9361-16i recognized but stops working Nov 1, 2019
RAID Controllers and Host Bus Adapters Impossible to create new hard drive group and virtual drive on LSI/Avago MegaRaid 9265-8i? Apr 19, 2016
RAID Controllers and Host Bus Adapters LSI / Avago CacheCade incredibly slow? Apr 8, 2019
RAID Controllers and Host Bus Adapters Broadcom (LSI/Avago) HBA and RAID Controller Technical Discussion Apr 6, 2019
RAID Controllers and Host Bus Adapters Does my AVAGO-LSI SAS3i 9300 make BSOD? May 1, 2018

Share This Page