Anyone have details on the HP P430?

Discussion in 'RAID Controllers and Host Bus Adapters' started by arglebargle, May 13, 2019.

  1. arglebargle

    arglebargle H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈

    Joined:
    Jul 15, 2018
    Messages:
    627
    Likes Received:
    198
    Can anyone who's worked with the p430 answer a quick question for me? I can't find the answer to this anywhere Google crawls.

    Does the p430 work in HBA mode without its cache module?

    I spent some time overnight getting an H240 working in one of my servers and it got me thinking about whether or not this was an option too. There are absolute shedloads of these on eBay and I'm pretty sure you could pick them up for $35 from the right seller, which is a pretty insane price for a SAS3 HBA with this performance.

    HPE Smart Array P430 Controller

    Paging @Patriot , I've seen you mention these boards a number of times while I was searching the forum for information on both.
     
    #1
    Last edited: May 14, 2019
  2. tomaash

    tomaash Member

    Joined:
    Oct 11, 2016
    Messages:
    58
    Likes Received:
    28
    I'm considering P430 for all flash 8-10disk expander R6 or R50 SAS array in DL360p Gen8.
    Cost of the double-wide cable is almost more than the controller with 4GB FBWC.
     
    #2
  3. arglebargle

    arglebargle H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈

    Joined:
    Jul 15, 2018
    Messages:
    627
    Likes Received:
    198
    That's amazing.

    FWIW if you're willing to run ZFS instead of HW RAID you could just pick up an H240 instead and use standard SFF-8087 cables. I don't know how well the H240 or P430 support expanders, I've heard some horror stories from people about the 25 SFF bay gen8 chassis with the expander built into the backplane and I don't know if that's the fault of the backplane or the HBA.
     
    #3
    Last edited: May 14, 2019
  4. Patriot

    Patriot Moderator

    Joined:
    Apr 18, 2011
    Messages:
    1,246
    Likes Received:
    649
    p430 and p440 are the same base controller, p430 was released mid-gen and supports traditional supercap backed flash whereas the p440 cache plugs into the mobo which has a system central battery backup of a pair of 18650s. I don't see why it wouldnt work as hba in zero memory mode... but idk... where are they $35
     
    #4
  5. arglebargle

    arglebargle H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈

    Joined:
    Jul 15, 2018
    Messages:
    627
    Likes Received:
    198
    eBay, I was going to spend some time lowballing the vendors with large quantities in stock and see if I can get the prices down to around $40 somewhere then post about it. $35 is optimistic, but someone might want to liquidate so who knows.

    The H240 at least performs really well on Linux, it's a shame more people don't know about/use them and if the P430 is comparable, hey, why not source them cheap?

    I'll go fishing for a cheap P430 and see if it works out, I was just hoping to know if there were any obvious HP gotchas before wasting a bunch of time.
     
    #5
    Last edited: May 14, 2019
  6. tomaash

    tomaash Member

    Joined:
    Oct 11, 2016
    Messages:
    58
    Likes Received:
    28
    #6
    arglebargle likes this.
  7. arglebargle

    arglebargle H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈

    Joined:
    Jul 15, 2018
    Messages:
    627
    Likes Received:
    198
    Let me know how putting the board in HBA mode goes would you?

    If you run into trouble with the board not initializing during POST try the older firmwares. My H240 had problems POSTing with 6.88 (most recent) but works fine with 5.04. I haven't spent the time to walk the versions forward and see what happens yet.
     
    #7
  8. tomaash

    tomaash Member

    Joined:
    Oct 11, 2016
    Messages:
    58
    Likes Received:
    28
    Sure thing - it will take some time to arrive here via eBay global shipping program though. And I need to find that bloody cable, which alone seems to cost 50+ EUR here... and there's no sign of it on eBay.

    I'll be using it in DL360p Gen8, which is totally supported config, so I don't expect any issues really.

    I have also H240, which was giving me some errors about missing battery and something about cache, which turned iLO health status to amber, so I moved it to DL20 Gen9 and run it in raid mode there with no issues whatsoever.
     
    #8
  9. arglebargle

    arglebargle H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈

    Joined:
    Jul 15, 2018
    Messages:
    627
    Likes Received:
    198
    Yeah, I have an H240 in a Gen8 and I get the same complaints at boot as well, but otherwise it boots normally. There was one oddity, if I disable the onboard P420i (nothing is plugged into it, I have the drive cages hooked up to the H240) then the machine takes an absolute age to boot, but if I leave it enabled and just don't use it then the machine boots at normal speed. Both adapters pause for a few moments to tell me that there are zero logical volumes configured but boot without issue after that.

    iLO actually shows OK/green status for me for storage, I wonder why it's showing errors for you. Did you have cache/battery plugged into the onboard storage adapter? That's the only thing I can think of that might be different here, I had those installed so I just left them that way.

    Did you end up ordering cables for the P430? It looks like I'm going to end up spending the difference in cost between the H240 and P430 on that 8-lane wide SFF-8087 cable. Oops, just re-read.

    Re Cables: It looks like the P430, P830, P440 and P840 all use the same uncommon double-wide SFF-8087 8 lane connector. I ran searches for cables for all of those cards and you've got a lot of options depending on what style end you need for the backplane. I guess if you're going to be using it in a DL360p you could just hunt down the cable HP designed for that configuration and not have to dick around with routing or length issues.
     
    #9
    Last edited: May 14, 2019
  10. tomaash

    tomaash Member

    Joined:
    Oct 11, 2016
    Messages:
    58
    Likes Received:
    28
    Actually I recall I tested H240 in ML310e Gen8 v2, which has no onboard P-series controller.

    Just ordered the cable. I went for DL360p specific one (762721-B21/762721-B21), since I couldn't find any other alternative that would be long enough. Cost me 60€ shipped, so I hope all this endeavor will be worth it :-D My use case is Raid50 or Raid6 performance with 8x 1.92TB read intensive SAS SSDs on 10GbE.
     
    #10
Similar Threads: Anyone details
Forum Title Date
RAID Controllers and Host Bus Adapters [FIXED] anyone here know how to fix/replace a SFF-8643 female connector? Dec 5, 2018
RAID Controllers and Host Bus Adapters [CLOSED]does anyone know how to HP 487738-001 sas with SuperMicro X8DT3-LN4F Motherboard? Aug 29, 2018
RAID Controllers and Host Bus Adapters anyone have more info about HP H240 HBA? Jun 10, 2018
RAID Controllers and Host Bus Adapters Anyone ever used the new highpoint SSD7110 nvme raid controller? Jan 22, 2018
RAID Controllers and Host Bus Adapters NVMe RAID 5/6??? Anyone running it? Oct 9, 2017

Share This Page