Anybody seen a Supermicro board not recognize hard drives/SSDs before?!

AveryFreeman

consummate homelabber
Mar 17, 2017
411
52
28
41
Near Seattle
averyfreeman.com
Hey,

I got a new board recently to upgrade my oddball UIO case server, it's an X10SRW-F, which is like a WIO form factor X10SRL-F

My BIOS is rev 3.22 (latest) and IPMI Redfish 3.9 (also latest - just updated both last night)

I was really excited to set this board up and retire my X9SPU-F, but I keep running into problems. First, there was no "optimal" fan speed setting and it wouldn't respond to ipmitool/ipmicfg raw fan speed settings, which is an entirely separate thread: No "Optimal" Fan speed setting?!

But now I've got my SSDs connected to its SATA controller - it's a wellsburg c612 standard integrated controller - and it doesn't recognize them in the BIOS. They're connected directly, not through backplane.

I've tried "AHCI" and "RAID" both with the following settings: spin-up (yes/no), hot plug (on/off). Aggressive link power settings (on/off). BIOS just doesn't see them. And, of course, the drives are not being seen by the OS (esxi 7.0U1c), either. I've tried turning on/off SR-IOV and ASPM.

Here's the REALLY weird thing: The two SATA controllers (SATA and sSATA) are detected in ESXi! Just not any drives. So weird!

I've got an LSI 2008-based 9212-4i4e in it, too, and was wondering if maybe there's some kind of interaction going on (?). The only thing I haven't tried is taking out the LSI controller and switching the cables.

I know the SSDs work cuz they were in this very case with my old board. With these same cables.

Any ideas about what I can do? Who's even SEEN something like this before?

UPDATE:

I think I finally figured it out

I had a molex-> 2x SATA power splitter. I was using it just that way with the two SSDs on the old motherboard, and they were both detected without issue.

I noticed on this board that if either was detected, it would only be one at a time. So I finally thought maybe the SSDs aren't getting enough power - one is a dual mSATA RAID1 with a couple old 24GB SLC SSDs so it probably uses a little more power than usual.

I am not using the mSATA RAID1 on this board - I was using it to boot ESXi on the old board because it had issues reliably booting from a USB flash drive, but on the new board it appears to work fine.

I unplugged it from the power splitter, booted the server, and sure enough, the other SSD (an 800GB S3500) showed up fine.

So I'm guessing that's what it was. I could try using another molex->SATA power adapter on a separate molex power connector (PDU only has molex) and plug in the old mSATA RAID1 to see if that was indeed what it was, but I don't really care at this point and I have other issues I'm trying to iron out on this board I need to get to, anyway.

It's kind of odd to me that the two SSDs would work fine on the same power splitter on the old board, but I guess some controllers are more temperamental than others.

Thanks to all who helped.
 
Last edited: