AMD Epyc 7502 (ES-04) + Asrock ROMED8-2T + Nemix ECC RDIMM - RAM not recognized

vkEnthusiast

New Member
Nov 26, 2020
7
1
3
Motherboard and ram(8x16GB DDR4 NEMIX 3200MHz Registered 2Rx8) are brand new.
BIOS is updated to the latest v1.30.
All dimms get recognized as 0GB even though the temperature reporting seems to work.

Haven't contacted AsRock support yet, but just realised that I managed to get pretty much the only brand which is not on AsRock Rack Memory QVL ... #iamverysmart.
I guess I was under impression that if all parameters match with requirements it should work... Another thing that potentially influenced my decision was the abundance of ads on Amazon, where even NEMIXRAM seller claims their ram is supported by AsRock EpycD8-2T, although it's LRDIMM, not RDIMM....

What is kinda suspicious, is the sketchy quality of the sticker: it's black&white and is already worn-out. All NEMIX dimms I see online have colored stickers, even the seller(nvtek) who sold me this ram, and yet he sent me this...
Did I get a fake/counterfeit ram? Can anything be done to get it working with this motherboard or should I just try to return it?

Edit: I am getting more suspicious - this is how this dimm looks on NEMIX website

And the dimm I got has modules 61b77, which in accordance to google are micron chips...
 

Attachments

Last edited:

bayleyw

Active Member
Jan 8, 2014
115
37
28
Hmm it does boot off live Ubuntu. So it's just SPD and the ram itself is fine, right?
Does this mean I shouldn't worry about its possible inauthenticity and there's no need to return it?
Well it very well might not be Nemix branded RAM, but fundamentally all RAM comes from the same few die vendors and its not like the Nemix stuff was particularly high end. Just run it through a few days of Memtest and if it survives I'd roll with it.
 
  • Like
Reactions: vkEnthusiast

jpmomo

Active Member
Aug 12, 2018
260
85
28
i have the same setup with the nemix ram. I think it is just an issue with it not displaying on the first page of the bios. everything else seems to be ok. it even shows the temp for all 8 ram dimms.
 

vkEnthusiast

New Member
Nov 26, 2020
7
1
3
Thank you guys for the feedback.
I ended up reusing existing ubuntu 18.04 installation from a old pc - so far things look alright.

Unrelated to the ram itself(might rename the thread to a "build log" later lol) but just wanted to share this story ...

As I mentioned I updated BIOS to v1.30. Everything seemed fine up until the moment when I realized that the 4pin NF-A15 PWM fan(sits on NH-U14S TR4-SP3 cpu cooler) is not spinning anymore.

Found a couple of old 4 and 3 pin fans, they all worked fine on the same fan header(and on all other headers). NF-A15 also was making attempts to work when placed poorly on the header i.e. I first thought it's an issue with the cord/contact as this is a used cooler+fan combo, but something looked off.

While rebooting the system yet another time I noticed that a)it's now taking way longer (at least a minute or two till POST[as the flag to wait for BMC was on]) BMC version is empty, and b) BMC Self test status as Failed. So NF-A15 was acting up because its pwm is controlled by BMC on that AST2500 ASPEED chip.
BMC heartbeat LED was not blinking anymore.

Let's try to reflash it(via DOS on usb) ... but I can't reflash it because socflash simply says "Error Can't find the Device"

A wild wise idea came into my head that "hey, maybe it's not the BMC, but the fresh BIOS". Rolled the BIOS back to v1.10. Rebooted a couple times...nope. Turned the pc off, shut the PSU down and went to bed as it was 2am.

Today I wake up, turn the PSU on and oh wow! BMC heartbeat LED is back and NF-A15 is spinning.

I should've listened to AsRock's "We don’t recommend users to update the BIOS/BMC if their system is already running normally" lol
 

amir_sta

New Member
Dec 13, 2020
3
1
3
Sorry, as it might be a little off-topic.
I decided to post here as I'm planning to use the same setup described here (Epyc 7502 (ES-04) from eBay with ASRock ROMED8-2T motherboard)
I have never worked with server CPUs and MBs, so I thought not to put myself in trouble and to get some help and guidance first.
Have you had any other problems other than memory? Does the motherboard read the CPU without any issues?
Does anyone have any comments or advice for me?
I'm planing to use this workstation for my Data Science projects.
Any help and advice are appreciated.

Thanks a lot
 

vkEnthusiast

New Member
Nov 26, 2020
7
1
3
@amir_sta I couldn't open that url.
It's been less than a week since I have it so hopefully other residents will drop a word or two as I'd be happy to hear about their unique experience with this creature lol.
(unrelated to the cpu+mobo, if you're in Canada and will be ordering that cpu on eBay from a seller in US, pm me as there is a very important moment about duties&taxes and FedEx/ups clearance fees, which can cost up to 40% extra)

So far the 0GB ram question mentioned above and the BMC quest are the only things which got me confused. The BMC issue was definitely a shitty moment as I though I'd have to get support involved. Now I really hope I won't need to touch it again.
I haven't noticed anything with the cpu itself, tried loading it a couple times for 1 or 2h and it looked fine.

If you go with this combo make sure you get "registered" ddr4 ECC type of ram, not the unbuffered one.

As this is a server board, the things you might not be expecting are: the board has no audio chip(i.e. no audio jack) and no wifi, but that BMC chip supports VGA. And you'll most likely need 2 RJ45 cables(one for internet and one for ipmi).

Do you already have a case for it? If you don't then get a "PC Cable Power/Reset Button" on amazon. I tried reusing one ATX PC case but it was an awkward fit so it's currently in an open-air mode(with an extra fan facing VRM) and I'm thinking about getting smth like Chenbro 42300, or any other 4u case.

Speaking about the case - if you are you going to start with an air cooler I need to warn you that apparently nh-u14 will be too tall to fit in a 4u case later, so maybe try booting with smth inexpensive like "NH-U12 tr4-sp3" first.
If you decide on liquid cooling right away, it seems that Optimus and "Watercool Heatkiller iv tr4-pro" blocks are the best performance-wise.
And avoid Enermax AIO.

As for the mobo - I'm not sure if m2_1 slot is working properly, but m2_2 works fine. As per release notes in asrock's ROMED8-2T download section this was one of the fixes in that v.1.30 bios.

I'm actually curious if anyone else had positive experience with reflashing BMC on their Asrock mobos recently.
 

larrysb

Active Member
Nov 7, 2018
107
47
28
Hmm it does boot off live Ubuntu. So it's just SPD and the ram itself is fine, right?
Does this mean I shouldn't worry about its possible inauthenticity and there's no need to return it?

The screen shot appears to show your RDIMMs have incomplete SPD ROM data on them. They show no vendor ID, they all show the same serial number. Properly provisioned DIMMs, especially server dimms, will have complete and correct SPD data, with vendor ID, serial numbers, even date of manufacture. Not sure why your bios isn't displaying it, but it is possible the SPD data is incomplete or incorrect. It certainly isn't what I'd expect.

I've had better luck with top-tier brand server pulls than I've had with lower-tier new memory.

You might ask Nemix if your sticks are legit. Stickers are cheap, as are non-name sticks made of sweeps from random production lines...
 
  • Like
Reactions: vkEnthusiast

vkEnthusiast

New Member
Nov 26, 2020
7
1
3
@larrysb thanks! I just tried replacing those 8x16 with a 2x32 Kingston KSM32RD4/32MEI and not only did it get recognized by bios right away but I also see what you meant by saying that the SPD data is missing. (screenshot attached)

@jpmomo hey you mentioned that you have the same setup with NEMIX ram. Just wondering do you get the same underreporting when you run "sudo dmidecode -t memory" or is it as verbose as on the screenshot this pic?
 

Attachments

  • Like
Reactions: larrysb

larrysb

Active Member
Nov 7, 2018
107
47
28
Gamer memory frequently has incomplete SPD data, but server sticks in my experience always have full data. Don't think I'd trust memory that didn't.
 

jpmomo

Active Member
Aug 12, 2018
260
85
28
@larrysb thanks! I just tried replacing those 8x16 with a 2x32 Kingston KSM32RD4/32MEI and not only did it get recognized by bios right away but I also see what you meant by saying that the SPD data is missing. (screenshot attached)

@jpmomo hey you mentioned that you have the same setup with NEMIX ram. Just wondering do you get the same underreporting when you run "sudo dmidecode -t memory" or is it as verbose as on the screenshot this pic?
as previously mentioned, the memory appears to function correctly but is just missing the manufacturer details. all the other relevant info is recognized.

Handle 0x002B, DMI type 17, 84 bytes
Memory Device
Array Handle: 0x0023
Error Information Handle: 0x002A
Total Width: 72 bits
Data Width: 64 bits
Size: 32 GB
Form Factor: DIMM
Set: None
Locator: DIMM 0
Bank Locator: P0 CHANNEL A
Type: DDR4
Type Detail: Synchronous Registered (Buffered)
Speed: 3200 MT/s
Manufacturer: Unknown
Serial Number: 033DE95D
Asset Tag: Not Specified
Part Number:
Rank: 2
Configured Memory Speed: 3200 MT/s
Minimum Voltage: 1.2 V
Maximum Voltage: 1.2 V
Configured Voltage: 1.2 V
Memory Technology: DRAM
Memory Operating Mode Capability: Volatile memory
Firmware Version: Unknown
Module Manufacturer ID: Unknown
Module Product ID: Unknown
Memory Subsystem Controller Manufacturer ID: Unknown
Memory Subsystem Controller Product ID: Unknown
Non-Volatile Size: None
Volatile Size: 32 kB
Cache Size: None
Logical Size: None