4 Way SLI Trouble with Asus Z10PE-D8 WS

Discussion in 'Processors and Motherboards' started by SenpaiStudios, Sep 24, 2017.

  1. SenpaiStudios

    SenpaiStudios New Member

    Joined:
    Sep 24, 2017
    Messages:
    2
    Likes Received:
    0
    System Specs:

    2x Intel Xeon E5-2687W V4
    Asus Z10PE-D8 WS (BIOS Revision 3407)
    8x16GB Kingston RAM @2400Mhz
    4x Nvidia GTX Titan X
    3x Intel 750 NVME Drives 1.2TB (AIC)
    1x Intel 750 NVME Drive 1.2TB (m.2)
    Corsair AX1500i

    I recently completed my build but I'm having some trouble with q-code error D4, PCI resource allocation error. Out of resources. When this happens, in the post screen, it only detects 3 out of 4 of the NVME drives, one of the missing ones being an AIC. I confirmed that the one connected via m.2 is always detected.

    I'm mostly positive that I had all 8 PCIe devices working before I filled the initial loop, this was with E5-2670 V3 processors. Unfortunately I can't say for sure, just based off of memory and logical reasoning that I wouldn't have filled the loop with liquid unless everything worked... That being said, I got the error right after I filled and have never successfully made it to windows. The system sat for a bit, and in the meantime, I managed to procure some E5-2687W V4s to replace the odd stepping E5-2670V3s I had. Swapping CPUs unfortunately did not fix my problem.

    Things I've tried:
    All NVME devices were tested in another system and confirmed 100% working. I tried each GPU one at a time in the top PCIe slot and they all successfully displayed video.

    The best result I've gotten so far is 3 GPUs and all 4 NVME devices to be working in the Z10PE-D8 WS. This is without a GPU in slot 7.

    Even with all NVME devices (including the m.2) unplugged, the system still throws the D4 error when all 4 GPUs are plugged.

    I tried installing only 2 GPUs, in slot 1 and 7 and this successfully booted. No nvme devices were plugged in.

    What surprised me the most is that I was able to successfully boot with 3 GPUs, 4 NVME devices, and an AC1900 WiFi card in slot 7...

    I've tried a 5th Titan X GPU in slot 7 in place of the original, but I get the same D4 error.

    The Tl;dr is that the problem seems unrelated to the NVME drives and for some reason I just can't run 4 GPUs on my motherboard. I'm going to try running a GTX 1080 in slot 7 next and see if that helps at all.

    Thanks guys!
     
    #1
  2. i386

    i386 Well-Known Member

    Joined:
    Mar 18, 2016
    Messages:
    1,777
    Likes Received:
    444
    [​IMG]

    I see two pcie slots that go to x0 mode when add in cards are used in other slots.
    I think that one of devices gets full access to the lanes and "blocks" lanes on the the other pcie slot.
     
    #2
  3. SenpaiStudios

    SenpaiStudios New Member

    Joined:
    Sep 24, 2017
    Messages:
    2
    Likes Received:
    0
    I believe X0 is a poor way of displaying that when there's nothing plugged into that slot, the slot above it operates at X16, and if both slots are occupied they get X8.

    That aside, the problem has been solved. Shortly after writing this I tried enabling 4g decoding, just to see, and wouldn't ya know it, it worked...
     
    #3
  4. MiniKnight

    MiniKnight Well-Known Member

    Joined:
    Mar 30, 2012
    Messages:
    2,965
    Likes Received:
    871
    Did you do a cmos clear? Sometimes when you add more pcie devices you need to do that in order to stop random errors. I've seen it more than a few times on our systems.
     
    #4
Similar Threads: Trouble Asus
Forum Title Date
Processors and Motherboards Troubleshooting - Intel S2600CP2J Won't POST, No Video Jul 20, 2019
Processors and Motherboards X11SSH-LN4F trouble creating EFI partition on NVMe drive Jun 6, 2019
Processors and Motherboards X9DRW-3TF+ Troubleshooting Nov 12, 2018
Processors and Motherboards X9DRW-iF wierd boot issues & troubleshooting Oct 21, 2018
Processors and Motherboards Trouble with booting Intel S2600CP4 with Samsung RAM from HK Aug 25, 2017

Share This Page