Cisco “ip dhcp pool 20” in Arista?

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Richard Sanchez

New Member
Nov 6, 2016
7
0
1
Hi Guys,
How do I convert the Cisco command

ip dhcp pool 20

for an Arista switch?
I have switch Firmware 4.25.1F which has the new DHCP server capability.
Context of command below.
Thanks
Rich



vlan 10

name PC

exit



vlan 20

name WIFI

exit



vlan 30

name Printer

exit



show vlan



conf t



interface range fastEthernet 0/1-16

switchport mode access

switchport access vlan 10

exit



interface range fastEthernet 0/17-32

switchport mode access

switchport access vlan 20

exit



interface range fastEthernet 0/33-42

switchport mode access

switchport access vlan 30

exit



show vlan



conf t



interface vlan 10

ip address 10.10.10.1 255.255.255.0

no shutdown

exit



interface vlan 20

ip address 10.10.20.1 255.255.255.0

no shutdown

exit



interface vlan 30

ip address 10.10.30.1 255.255.255.0

no shutdown

exit



show ip interface brief



conf t



ip routing



ip dhcp pool 10

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 8.8.8.8 4.2.2.2

exit



ip dhcp pool 20

network 10.10.20.0 255.255.255.0

default-router 10.10.20.1

dns-server 8.8.8.8 4.2.2.2

exit



ip dhcp pool 30

network 10.10.30.0 255.255.255.0

default-router 10.10.30.1

dns-server 8.8.8.8 4.2.2.2

exit
 

Mwilliamson

New Member
Aug 15, 2020
19
7
3
Fenton, Michigan, USA
In Cisco's terms, the "20" part of the ip dhcp pool command is really a Name to define the name of the pool. It's meant to be a variable to be called when you apply the pool to a VLAN. For example, you define a pool with "ip dhcp pool FIRSTFLOOR" or "ip dhcp pool IM-A-LITTLE-TEAPOT" as a way for both you and the switch to differentiate between different pools.

I don't have any experience with Arista devices, but I would assume that any equivalent command would have a similar structure to define a pool's name.
 

legopc

Active Member
Nov 2, 2014
226
38
28
28
The Netherlands
Looks like the proper Arista doc is behind login. If you have it you could find it here Arista EOS Central - User Management

Otherwise, it looks like these are the commands to make it work (apart from the specific configuration)
dhcp server
!
subnet 10.10.8.0/22
dns server 8.8.8.8
default-gateway 10.10.8.1
range 10.10.8.101 10.10.8.149
interface vlan10
dhcp server ipv4
 
  • Like
Reactions: Richard Sanchez

klui

Well-Known Member
Feb 3, 2019
824
453
63
Arista's DHCP server is built in after 4.23 or something like that. Before that threshold you need to install an swi package.

Just use the latest UM which is available w/out a login.

Code:
interface INTERFACE
dhcp server ipv4
 .
 .
 .